Discuss: MyBB 1.2.7 Released - Security & Maintenance Release
#21
Quantage Wrote:It broke my MyBB, lol.

I uploaded all of the files. And when I try to go to home/install/upgrade.php it comes up with this :/

Warning: require_once(/home/quantage/public_html/usf/inc/db_.php) [function.require-once]: failed to open stream: No such file or directory in /home/quantage/public_html/usf/install/upgrade.php on line 25

Fatal error: require_once() [function.require]: Failed opening required '/home/quantage/public_html/usf/inc/db_.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/quantage/public_html/usf/install/upgrade.php on line 25

If I try to go to my main directory, I get a message saying that MyBB isn't installed.

Please help Smile
Thanks,
~Matt

I had the same problem, but i found this and it fixed it.
I uploaded all the files and overwrote the existing ones, including the config.php file.

this fixed it for me
DrPoodle Wrote:Here is the code you need to put in the new config.php. Make sure you edit the database configuration variables to what they should be...
<?php
/**
 * Daatabase configuration
 */

$config['dbtype'] = 'mysql';
$config['hostname'] = 'localhost';
$config['username'] = '';
$config['password'] = '';
$config['database'] = '';
$config['table_prefix'] = 'mybb_';

/**
 * Admin CP directory
 *  For security reasons, it is recommended you
 *  rename your Admin CP directory. You then need
 *  to adjust the value below to point to the
 *  new directory.
 */

$config['admin_dir'] = 'admin';

/**
 * Hide all Admin CP links
 *  If you wish to hide all Admin CP links
 *  on the front end of the board after
 *  renaming your Admin CP directory, set this
 *  to 1.
 */

$config['hide_admin_links'] = 0;

/**
 * Data-cache configuration
 *  The data cache is a temporary cache
 *  of the most commonly accessed data in MyBB.
 *  By default, the database is used to store this data.
 *
 *  If you wish to use the file system (inc/cache directory)
 *  you can change the value below to 'files' from 'db'.
 */

$config['cache_store'] = 'db';

/**
 * Super Administrators
 *  A comma separated list of user IDs who cannot
 *  be edited, deleted or banned in the Admin CP.
 *  The administrator permissions for these users
 *  cannot be altered either.
 */

$config['super_admins'] = '1';
 
?>

So change all of these to what they should be to connect to your database:

$config['dbtype'] = 'mysql';
$config['hostname'] = 'localhost';
$config['username'] = '';
$config['password'] = '';
$config['database'] = '';
$config['table_prefix'] = 'mybb_';



Also im having a problem with alot of the modifications i use.
Some of them give me this error after i upgraded:
Quote:Depreciated function call: update_thread_count
they never did this until this previous upgrade. I dont know how to fix them, so i just deactivated them for now and the error is gone.
#22
TAEL Wrote:I Have MyBB 1.2.6 , Which Attachment I Should Download ?!

Thanks.

http://community.mybboard.net/attachment.php?aid=6238

There are alot of files that need replacing.

Then, after there all uploaded. Go to: http://www.yoursite.com/yourMybb/install/upgrade.php

Run through all of that then you have successfully upgraded it all.

You may delete the install directory once you have successfully upgraded it.
#23
Should I Backup Config.php & Settings.php ?!
Music Master , The Eldest Site About Music In Persian Language, Proudly By MyBB
#24
In case you accidentally overwrite them, yes, you should.

Following the instructions for upgrading you don't overwrite them but just in case - it is good to have a backup.
#25
Config.php & Settings.php arent even in the changed files. But just in case. Save them and if need be, upload them once you uploaded all the files.
#26
I keep getting worked up about 1.4...but thanks for keeping the 1.2.x line completely up to date. This is exactly why I use myBB over, say, SMF 2 or phpBB 3. Awesome work [again!].
[[ Web ]]
<SIGNATURE RULES ARE LAME>
[[ Mt. Moon Community ]]
#27
Fantastic.......

That couldn't have been simpler. I had a heart in mouth moment when I realised I hadn't backed up config.php or settings.php but it didn't overwrite them so that was cool.

It was the easiest upgrade ever.

Thanks Cool
#28
PHP_Paul Wrote:I keep getting worked up about 1.4...but thanks for keeping the 1.2.x line completely up to date. This is exactly why I use myBB over, say, SMF 2 or phpBB 3. Awesome work [again!].

i think SMF and phpbb are ugly. i dunno i just couldnt ever get into them. I love or did love IPB 2x, and mybb is the closest to it, but i think it'll become much better.

I'm exciting about 1.4 also. Alot of great features are gonna be in it! Big Grin
#29
The upgrade was a breeze Chris, and thanks to you and all of the progammers who participated in it. Smile

Only one suggestion.. And there's always plenty of them. Toungue

I use two rows of code-buttons in the editor, and again I had to split some params in editor.js; plus adding all of the other stuff.

Why not change the heightXwidth browser type to "subtract2" and "subtract3"

Makes it so much easier for those wanting to add extra code-buttons. Wink
		// Set the height of the area
		subtract = subtract2 = 0;
		if(MyBB.browser != "ie" || (MyBB.browser == "ie" && MyBB.useragent.indexOf('msie 7.') != -1))
		{
			subtract = subtract2 = 35;
		}
		areaContainer.style.height = parseInt(editor.style.height)-parseInt(toolBar.style.height)-parseInt(toolbar2.style.height)-subtract+"px";

		// Set the width of the area
		subtract = subtract3 = 0;
		if(MyBB.browser != "ie" || (MyBB.browser == "ie" && MyBB.useragent.indexOf('msie 7.') != -1))
		{
			subtract = subtract3 = 8;
		}

		areaContainer.style.width = parseInt(editor.style.width)-subtract3+"px";

I had done this for FF in v1.2.6, but v1.2.7 seems to have fixed the mozilla problem too. Smile

And the default would be height = 8, not 35 Lol!..

Great Job! Toungue
#30
Done! superb job thanks! Big Grin
Are we all we seem? Find out at www.thurrockparanormalforum.com
[Image: thurrockbanner.gif]


Forum Jump:


Users browsing this thread: 1 Guest(s)