Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 3 Years, 4 Months, 3 Weeks ago htaccess error along with SEO URLs error
#11
Solved: 3 Years, 4 Months, 3 Weeks ago
This user has been denied support. This user has been denied support.
If it tries to find a file "forum-5.html" even though you have a rewrite for it... your rewrites just don't work for some reason. Unless you've made an obvious mistake (it's literally ".htaccess", and not "htaccess.txt") or not running Apache in the first place, maybe ask your host what you have to do to make rewrites work.
Reply
#12
Solved: 3 Years, 4 Months, 3 Weeks ago
@OP : you may have to check something like this !
Reply
#13
Solved: 3 Years, 4 Months, 3 Weeks ago
(05-26-2016, 11:52 AM).m. Wrote: ^ you may have to check something like this !

Thank you very much for this, I took a look at my main config and noticed AllowOverride's were set to "none" meaning regardless of having mod_rewrite in phpinfo it couldn't be used.

For anybody experiencing my issue the exact place I enabled this option was the following:
<Directory "/var/www/html">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
    Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride All

#
# Controls who can get stuff from this server.
#
    Order allow,deny
    Allow from all

</Directory>

"AllowOverride All" was set to "AllowOverride None".


To add to this if you're not hosting your forum in the base directly like I was then you may need to copy this and change " <Directory "/var/www/html"> " to whatever subdirectory directory you're hosting your forum in.


Thanks again for all the help you've given.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)