Thread Rating:
  • 9 Vote(s) - 4.11 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] MyIPB theme
#21
Whenever you post a theme eNvy I download it. Love your creations and thank you for another beautiful theme!


Reply
#22
Hey I have a question related to the width of the theme.

I enjoy having a theme between 60% and 70% width, but there is this "issue"..

The site previews  ( u know those previews of your site for example in google chrome tabs ( the recent viewed sites) etc, it doesn't look good because of the scale to 70%..

Also when viewing on mobile devices ( for example a full hd smartphone) it also only fills 70% of the site. Which realy gets "buggy" etc..  (Yes, I do use the mobile plugin, but still).

Is it possible to make use of min-width px and max-width px for just the wrapper of the forum or something?

on top of that, what are the benefits of using procent instead of pixels?
Reply
#23
(06-21-2016, 12:24 AM)MikeInToshx Wrote: Hey I have a question related to the width of the theme.

I enjoy having a theme between 60% and 70% width, but there is this "issue"..

The site previews  ( u know those previews of your site for example in google chrome tabs ( the recent viewed sites) etc, it doesn't look good because of the scale to 70%..

Also when viewing on mobile devices ( for example a full hd smartphone) it also only fills 70% of the site. Which realy gets "buggy" etc..  (Yes, I do use the mobile plugin, but still).

Is it possible to make use of min-width px and max-width px for just the wrapper of the forum or something?

on top of that, what are the benefits of using procent instead of pixels?

The previews are always taken by the full site I think, so you can't do anything about that.

For mobile devices, the story is other. This theme uses fluid design, is not responsive at all, so expect it to be "buggy" or weird on mobile devices.

You can change the width of any element using pixels, but pixels are always pixels, a.k.a. fixed design (you can have a resolution of 4k but if you use 1024px it always gonna be 1024px no matter in which resolution do you saw the site. In mobile devices, it doesn't scale, so you're gonna get scroll bars everywhere.

Using percentage instead of pixels gives you the ability to adjust the width of the element with the resolution of the device you're using. For example, 100% of the device is always 100%, no matter if you are using 4k resolution or 1024, it always scale to 100% of the resolution.
I don't give support on PM.
Reply
#24
Envy, read messages if you haven't, love the themes you have made :]
Reply
#25
I see. Thx for clearing that up. I might just stick with percentage then.
Reply
#26
(06-21-2016, 01:05 AM)KaruleanX Wrote: Envy, read messages if you haven't, love the themes you have made :]

I read all my messages, at the moment I can't help you. If you have some errors or bugs in any of my themes, please post in the correct thread. Thanks.

(06-21-2016, 01:21 AM)MikeInToshx Wrote: I see. Thx for clearing that up. I might just stick with percentage then.

Yeah, is better sometimes, depends on the style. I don't do responsive design due to the old html structure (I can spend hours changing all the html but at the end, is useless in terms of compatibility with plugins).

Regards!
I don't give support on PM.
Reply
#27
Thanks man.
Reply
#28
There is some missing css for pagination I think.
Tried it myself but I struggle when it comes to those long css names.

       

First image I selected it so U can see what is missing.

It's when having more than 1 page in search results. the font color is white.
Can't just change the color for pagination because then the pagination in postbit would be changed too.
Reply
#29
(06-23-2016, 03:04 PM)MikeInToshx Wrote: There is some missing css for pagination I think.
Tried it myself but I struggle when it comes to those long css names.



First image I selected it so U can see what is missing.

It's when having more than 1 page in search results. the font color is white.
Can't just change the color for pagination because then the pagination in postbit would be changed too.

I didn't even touch the search template xD

This is the fix:

1- search_results_threads template

Replace all the code of the template with this new one:

<html>
		<head>
		<title>{$mybb->settings['bbname']} - {$lang->search_results}</title>
		{$headerinclude}
		</head>
		<body id="search">
		{$header}

		<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
			<tr>
				<td colspan="8" class="thead">
					<strong>{$lang->search_results}</strong>
				</td>
			</tr>
			<tr>
				<td class="lightblue" colspan="8">
					<span style="float: left;">{$multipage}</span>
				</td>
			</tr>
			
			<tr>
				<td class="tcat" align="center" colspan="3" width="56%"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=subject&amp;order=asc">{$lang->thread}</a> {$orderarrow['subject']}</strong> / <strong><a href="{$sorturl}&amp;sortby=starter&amp;order=asc">{$lang->author}</a> {$orderarrow['starter']}</strong></span></td>
				<td class="tcat" align="center" width="14%"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=forum&amp;order=asc">{$lang->forum}</a> {$orderarrow['forum']}</strong></span></td>
				<td class="tcat" align="center"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=replies&amp;order=desc">{$lang->replies}</a> {$orderarrow['replies']}</strong></span></td>
				<td class="tcat" align="center"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=views&amp;order=desc">{$lang->views}</a> {$orderarrow['views']}</strong></span></td>
				<td class="tcat" align="center" width="200"><span class="smalltext"><strong><a href="{$sorturl}&amp;sortby=lastpost&amp;order=desc">{$lang->lastpost}</a> {$orderarrow['lastpost']}</strong></span></td>
				{$inlinemodcol}
			</tr>
			{$selectall}
			{$results}
		</table>
		{$inline_edit_js}
		<table width="100%" align="center" border="0">
			<tr>
				<td class="lightblue" colspan="8">
					<span style="float: left;">{$multipage}</span>
					<span style="float: right;">{$inlinemod}</span>
				</td>
			</tr>
		</table>
		{$footer}
		</body>
		</html>

2- search_results_threads_inlinemoderation template

Replace all the code of the template with this new one:

<script type="text/javascript" src="{$mybb->asset_url}/jscripts/inline_moderation.js?ver=1807"></script>
		<form action="moderation.php" method="post" style="padding: 5px 8px;">
<input type="hidden" name="my_post_key" value="{$mybb->post_code}" />
<input type="hidden" name="fid" value="0" />
<input type="hidden" name="searchid" value="{$sid}" />
<input type="hidden" name="modtype" value="inlinethread" />
<span class="smalltext" style="color: #fafafa;"><strong>{$lang->inline_thread_moderation}</strong></span>
<select name="action">
	<optgroup label="{$lang->standard_mod_tools}">
		<option value="multiclosethreads">{$lang->close_threads}</option>
		<option value="multiopenthreads">{$lang->open_threads}</option>
		<option value="multistickthreads">{$lang->stick_threads}</option>
		<option value="multiunstickthreads">{$lang->unstick_threads}</option>
		<option value="multisoftdeletethreads">{$lang->soft_delete_threads}</option>
		<option value="multirestorethreads">{$lang->restore_threads}</option>
		<option value="multideletethreads">{$lang->delete_threads}</option>
		<option value="multimovethreads">{$lang->move_threads}</option>
		<option value="multiapprovethreads">{$lang->approve_threads}</option>
		<option value="multiunapprovethreads">{$lang->unapprove_threads}</option>
	</optgroup>
	{$customthreadtools}
</select>
<input type="submit" class="button" name="go" value="{$lang->inline_go} ({$inlinecount})" id="inline_go" />&nbsp;
<input type="button" onclick="javascript:inlineModeration.clearChecked();" value="{$lang->clear}" class="button" />
<input type="hidden" name="url" value="{$return_url}" />
<input type="hidden" name="inlinetype" value="search" />
</form>
<script type="text/javascript">
<!--
	var go_text = "{$lang->inline_go}";
	var all_text = "{$threadcount}";
	var inlineType = "search";
	var inlineId = '{$sid}';
// -->
</script>

That fix all ^^.
I don't give support on PM.
Reply
#30
I rather not replace full templates without knowing what changed. With plugins, mine look different etc and would only cause a mess if I do replace it with yours. Hope you understand..

I didn't mean directly the search template. I mean the font-color css that has been chosen for the pagination class, is white.
The pagination location background-color in the threads is a blue color, correct?
   


And in the search page, the background color is white.
   

When the pagination link color is also white, it's ofcourse not viewable with the white background.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)