Solved: 5 Years, 3 Months ago User Stars behaving oddly
#1
Solved: 5 Years, 3 Months ago
So to keep things simple, all our users are members of the same 'Registered' group, apart from the Admins. For a bit of fun, I created a set of Custom User Groups, each with its own 'Star' icon, then various users could have their Display User Group set to one of the special groups.

That meant that users could be assigned their own 'Stars' but with the number of stars still being derived from their post count and controlled from the User Titles config.

Everything was working fine, but as of today, I noticed that most have reverted to the regular star.png icon, but a handful work as they used to.

I can find no logic to what is going on here. Can someone explain the logic of the whole 'Default User Title' and 'User Stars' thing?

To illustrate what I mean, Avocet is a regular Registered User, but sarabande has been set to use a different group for his stars:

[Image: sara_zpsajc0t7qx.png]

If I look at sarabande's profile in ACP, you can see he is set to use a different Display User Group:

[Image: sacp_zpseh7wr9nl.png]

and here in the User Group, you can see the logo setting:

[Image: sug_zpspuy82wzb.png]

All well and good. But this guy has similar settings and his 'stars' don't show:

[Image: viago_zpsatnz9u6p.png]

His profile and user group are as shown:

[Image: vacp_zpsg171ccbi.png][Image: vug_zpsvn2crecb.png]
Reply
#2
Solved: 5 Years, 3 Months ago
Bump. I just set this up on the staging server and it works fine. Checked admin logs and no-one has changed anything on the live server. Anyone got a clue on this?
Reply
#3
Solved: 5 Years, 3 Months ago
Update:
Mystery solved.

All the affected users (bar one) had reached a post count where they tripped over into a group which had a Star Image set for the User Title. Why the outstanding user was affected I have no idea, but everything is fixed now...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)