Jump to the post that solved this thread.
Solved: 4 Years, 9 Months, 3 Weeks ago <!DOCTYPE html> Issue
#1
Solved: 4 Years, 9 Months, 3 Weeks ago
This user has been denied support. This user has been denied support.
Using validator.w3.org to try to remove errors. It's giving me:

Quote:Error: Almost standards mode doctype. Expected e.g. <!DOCTYPE html>.
From line 1, column 1; to line 1, column 121
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> ↩<htm

Whenever I replace my doctype with just <!DOCTYPE html> it fixes the error but breaks some parts of my forum. I noticed that community.mybb.com also uses that doctype.
Reply
#2
Solved: 4 Years, 9 Months, 3 Weeks ago
well, there is no such error when we validate this community forum (link) !
Reply
#3
Solved: 4 Years, 9 Months, 3 Weeks ago
This user has been denied support. This user has been denied support.
(2016-07-05, 04:27 AM).m. Wrote: well, there is no such error when we validate this community forum (link) !

I was using this page. Sorry for not being more specific.
Reply
#4
Solved: 4 Years, 9 Months, 3 Weeks ago
What do you mean by break your forum? You can change the doctype to HTML5, but there's many changes you then need to make to get your site to validate.
What goes around comes around
Reply
#5
Solved: 4 Years, 9 Months, 3 Weeks ago
<!DOCTYPE html> could indicate HTML 3 or HTML 5.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)