Thread Rating:
  • 8 Vote(s) - 2.63 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LegosJedi's Plugins and Modifications - First Custom Editor Theme Released!
#41
What other files, 772pilot?

LadyAngelique Wrote:never had it activated since i discovered those bugs...but am goin to update and see if all is well now...thanx dude!

EDIT: I have reinstalled it, reactivated it, made a test user a mod...now where am I suppose to see the link to the Mod CP now??? Cuz am not seein it in the header where the User CP link is...

EDIT #2: Err...I went to the direct link of the mod cp...
http://www.mysite/mod/ and when I tried loggin in as a mod under my mod test user alias...it wont log me it just keeps redirecting me to the mod cp login window as if I never even logged in...

Are you completely sure that the user is a moderator? I mean, he's not just in the moderator group, he's actually a moderator assigned to a forum, or a super mod.

Please do not PM me about problems you might be having with MyBB. Post a thread, and someone on the support or development team will take a look at it.
Reply
#42
Nevermind, I successfully installed it. However, I've edited the permissions for moderators, meaning that they have access to banning, but my test account, however, doesn't. I don't know if my real moderator has this problem too. Also, like LadyAngelique said, the link to the Mod CP isn't showing up in the header. Of course, I've tried to make the template for it, but nothing has happened. Other than that, nice plugin!
[Image: affbanner.png]
Reply
#43
LegosJedi, I am having the same problem where I can't see the modcp link in my header, I am admin but added myself as a moderator to a forum and updated the counters and still there's no link in my header, but my mod cp works fine when I go to it directly.

I see the global template for the header link but it's not adding itself, any ideas? Thanks.
Reply
#44
LegosJedi Wrote:What other files, 772pilot?

LadyAngelique Wrote:never had it activated since i discovered those bugs...but am goin to update and see if all is well now...thanx dude!

EDIT: I have reinstalled it, reactivated it, made a test user a mod...now where am I suppose to see the link to the Mod CP now??? Cuz am not seein it in the header where the User CP link is...

EDIT #2: Err...I went to the direct link of the mod cp...
http://www.mysite/mod/ and when I tried loggin in as a mod under my mod test user alias...it wont log me it just keeps redirecting me to the mod cp login window as if I never even logged in...

Are you completely sure that the user is a moderator? I mean, he's not just in the moderator group, he's actually a moderator assigned to a forum, or a super mod.

Gotcha!!! But what bout the link to the Mod CP??? Am not seeing that

Thanx in advance gain!

EDIT: Dude I just wanna say again...THANK U SO MUCH FOR THIS!!!! OMG!!!!

KEEP WORKIN ON YA OTHER MODS THAT YOU PROMISED US!!! AS I CANT WAIT TO SEE WHAT ELSE YOU COME UP WITH!!!!

This Mod CP is totally awesome and than some!!!!

Btw, how can I add this to the header navigation menu where User CP is so is right with the User CP & Admin CP links...thanx in advance gain!
Reply
#45
That's so weird, it works for me. Can someone provide me with a test admin account via PM? I'd like to check some templates and stuff.

Please do not PM me about problems you might be having with MyBB. Post a thread, and someone on the support or development team will take a look at it.
Reply
#46
There is a bug with table prefix. You use mybb_ but somebody can have other (for example meWink) And than plug-in can't activate and work.
-=mtbikes.info - vortal rowerowy=-
[Image: f32cee748caf9ff6.gif]
Najlepszy vortal rowerowy! Zapraszam!
Reply
#47
Create a template called header_welcomeblock_member_mod, containing the link to the mod cp. Then, where you want to link to be, try adding {$modcplink}. It hasn't worked for me, but it might work for you.
[Image: affbanner.png]
Reply
#48
Nice modifications,very nice plugin mod-cp Smile

Thanks LegosJedi
_______________________________________________

It is not disgraceful to ask, it is disgraceful no to ask.


sory for my english .
Reply
#49
leg has someone set u up with a test admin account for their mybb??? if not u can use mines on my forum...let me know if you still need a test admin account...i'll be ya guinea pig Big Grin

And has anyone got a modified stable code to add the modcp link to the header nav menu as yet???

huge thanx in advance
Reply
#50
przemu Wrote:There is a bug with table prefix. You use mybb_ but somebody can have other (for example meWink) And than plug-in can't activate and work.

Thanks, I've fixed that, and uploaded the new code in this page. You'll need to deactivate, upload, and reactivate the plugin, thought, just to let you know.

772pilot Wrote:Create a template called header_welcomeblock_member_mod, containing the link to the mod cp. Then, where you want to link to be, try adding {$modcplink}. It hasn't worked for me, but it might work for you.

Actually, you need this code:

 &mdash; <a href="{$mybb->settings['bburl']}/mod/index.php\">{$lang->welcome_mod}</a>

LadyAngelique Wrote:leg has someone set u up with a test admin account for their mybb??? if not u can use mines on my forum...let me know if you still need a test admin account...i'll be ya guinea pig Big Grin

And has anyone got a modified stable code to add the modcp link to the header nav menu as yet???

huge thanx in advance

Yeah, I still need an admin account. If you want to help, just PM with the info. Thanks!


Attached Files
.php   modcp.php (Size: 10.25 KB / Downloads: 93)

Please do not PM me about problems you might be having with MyBB. Post a thread, and someone on the support or development team will take a look at it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)