Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Feedback: PHP version requirements
I support OP's planned strategy.
I use a PHP extension which is not compatible with PHP7 (eg. need to rewrite thousands of lines of C code). I need to research to see if I can configure that app to use PHP5 as CGI while using PHP7 as mod_php for everything else.

I am anxious for the speedup and lower memory requirements PHP7 brings.
As the subject was recently mentioned on GitHub:

with 2 years elapsed since we have announced MyBB will not support PHP versions older than 7.0, the current plan (with 1.9 and subsequent 1.x branches in mind) is to have PHP 7.1 as minimum; that might be bumped again to PHP 7.2, depending on the actual release date for 1.9 (Active Support for PHP 7.1 ends December this year).

Despite having the focus shifted from writing 2.0 to incremental 1.x updates, we will continue to introduce changes that will make coding and maintenance easier for developers, and sticking close to most recent PHP branches will be one of them (more dynamic release cycle will help, as we will be reviewing the requirements with each minor version). (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪

Forum Jump:

Users browsing this thread: 1 Guest(s)