Not Solved Char ' causes signatures to 404
Not Solved
Hi guys,

I just found a problem with signatures on my website. I don't know what is causing it, but i just realized that some people were unable to update / preview signatures using the usercp. After i looked close I found that they all have the character ' in common. Removing that character from the signature made it act normally, what would be causing this?

Test user: demo
Test user password: 1234567890
Currently MyBB version: 1.8.7
Available to demonstrate it on:

You can easily type in anything and update / preview the signature.
Then add ' anywhere in the signature and it redirects you to my custom 404 error page (not found).

Not Solved
When you click on change signature, the textbox is prepopulated with the word Hi. What did you do to get that in there?

Edit: Nevermind, obviously you entered it there before on this account.

Have you tried uploading a fresh copy of usercp.php from the install package? I have confirmed your issue, but can't think of anything other than code that's causing it to break like that. Signing off your site now.
What goes around comes around
Not Solved
Does this happen on the default theme?

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Not Solved
Ashley1: no, i did not try to upload a fresh usercp.php because i did not edit it. Thanks for your help!
Ben C: yes.
Not Solved
Not Solved
(2016-07-25, 07:58 AM)Zak. Wrote: bump?

This must either be theme related or one of your files is corrupted / contains errors.

Under Tools & Maintenance in the ACP, click on file verification, what does it report there?

You can also try making a new theme and template set using the default templates, calling it test, and see if the problem persists.
What goes around comes around
Not Solved
Okay thanks for the adice, I started debugging the code. Seems like its a plugin issue.

And the ' in the signature still redirected to a 404.
Plugins i use:
Announcement (2.4.1)
Manage your own Announcements
Created by Jones

DVZ Mentions (0.5.1)
Parses @username into profile link with group color. Integrates with MyAlerts 2.0.x.
Created by Tomasz 'Devilshakerz' Mlynski
MyAlerts (2.0.2)
A simple notifications/alerts system for MyBB.
Created by Euan T

MySubscriptions (2.01)
Lets you implement paid subscriptions to groups within your forums.
Created by Ethan

Show the users that has been online today (2.0)
Shows the users that has been online within 24 hours.
Created by [[email protected]]CraKteR[/email]
Template Conditionals (1.8)
Allows you to use PHP conditionals in templates. This is the "safe" variant of the PHP and Conditionals in Templates plugin.
Created by ZiNgA BuRgA
Private Message Log (1.1)
Allows Administrators to view Private Messages sent on their board.
Created by Starpaul20

Username Change Approval, Limit and History (1.3.1)
Allows you to moderate username changes, limit username changes in a specific time period, and log all username changes.
Created by Starpaul20
Not Solved
Did you find the plugin causing this, if not you will have to deactivate them one by one and then test. Although looking at that list there are some well known plugins that i doubt will be causing this issue.
What goes around comes around
Not Solved
I looked through the inc/plugins and i search the php files for any "editsig" hooks, but nothing except Alerts.php which doesn't mess it up. I deactivated all the plugins and still it redirects to 404. I give up, I don't know what would cause it, is there a way to track whats hooked? I know this sounds like a high level coding but...

Forum Jump:

Users browsing this thread: 1 Guest(s)