Solved: 5 Years, 1 Week ago CHMOD? PERMISSION HELP PLS NEED IT NOW!
#1
Solved: 5 Years, 1 Week ago Thumbs Up 
Angry Angry Angry Angry Angry Angry Angry Help me
  • The configuration file (inc/config.php) is not writable. Please adjust the chmodpermissions to allow it to be written to.
  • The settings file (inc/settings.php) is not writable. Please adjust the chmodpermissions to allow it to be written to.
  • The cache directory (cache/) is not writable. Please adjust the chmod permissions to allow it to be written to.
  • The uploads directory (uploads/) is not writable. Please adjust the chmodpermissions to allow it to be written to.
  • The avatars directory (uploads/avatars/) is not writable. Please adjust the chmodpermissions to allow it to be written to.
idk now what it means...
i saw another thread from 2008, and they just said rename cache map to 777 i dont get it it looks like this for me:
http://imgur.com/a/FJcLP
4 images pls help me on forum or skype: live:zqusteamhacking1

My Server is running Ubantu, with apache2 installed.

Hosted by DigitalOcean.com
Reply
#2
Solved: 5 Years, 1 Week ago
Do you have ftp access to the uploaded files?
What goes around comes around
Reply
#3
Solved: 5 Years, 1 Week ago
(2016-07-24, 09:12 PM)Ashley1 Wrote: Do you have ftp access to the uploaded files?

yes
Reply
#4
Solved: 5 Years, 1 Week ago
Then you need to browse to those files in the ftp tool, right click and click on file permissions. Then set the permissions as required.
What goes around comes around
Reply
#5
Solved: 5 Years, 1 Week ago
EDIT2: Never mind what I said below. From the command line, go to your MyBB root, and run the following command as root:
chown -R www-data:www-data .

The problem is that apache/php will run as the user www-data, and should have ownership over the files, but your user (root) does right now because you uploaded the files as root.

If things don't work after running this, you can then try the steps below.

=====================================

Edit: partially ninja'd by Ashley

It seems to me like those permissions should have been sufficient, but since they aren't, try these steps:

For inc/config.php and inc/settings.php, right click the file, select "File permissions" (which should be the last option in the list), then give "Owner" and "Group" both read and write access, and world can have read only.

For cache/ and uploads/ (and we'll take care of the avatars folder in this too), right click the folder, select "File permissions" again, and give read, write, and execute to user, group, and world (check all the boxes in the matrix). There should be an option to "recurse into subdirectories." If present, select that. If not, repeat these steps if uploads/avatars/ isn't already drwxrwxrwx in the Permissions (Rättigheter) column.
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
Reply
#6
Solved: 5 Years, 1 Week ago
(2016-07-24, 09:24 PM)Josh H. Wrote: EDIT2: Never mind what I said below. From the command line, go to your MyBB root, and run the following command as root:
chown -R www-data:www-data .

The problem is that apache/php will run as the user www-data, and should have ownership over the files, but your user (root) does right now because you uploaded the files as root.

If things don't work after running this, you can then try the steps below.

=====================================

Edit: partially ninja'd by Ashley

It seems to me like those permissions should have been sufficient, but since they aren't, try these steps:

For inc/config.php and inc/settings.php, right click the file, select "File permissions" (which should be the last option in the list), then give "Owner" and "Group" both read and write access, and world can have read only.

For cache/ and uploads/ (and we'll take care of the avatars folder in this too), right click the folder, select "File permissions" again, and give read, write, and execute to user, group, and world (check all the boxes in the matrix). There should be an option to "recurse into subdirectories." If present, select that. If not, repeat these steps if uploads/avatars/ isn't already drwxrwxrwx in the Permissions (Rättigheter) column.


Attached Files Thumbnail(s)
   
Reply
#7
Solved: 5 Years, 1 Week ago
You need the period (.) at the end of the command, which means "current directory." Also, make sure you run it from the MyBB root (it doesn't look like you are at the moment).
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)