Solved: 4 Years, 8 Months ago Problems while attaching file to thread
#1
Solved: 4 Years, 8 Months ago
Hi all, I have a strange behaviour using MyBB version 1.8.7.
In a new thread, or a reply, when I try to upload a file (image file for instance) I get a white page, right after the upload (I see from Chrome the 100% of the upload).
This is the browser error I get:

   

You can see the Error 500.
If I open the source of the page, I see this lines at some point:

<tr>
<td class="trow1">Can not upload file - Too large for php post_max_size directive. Please press the back button.</td>
</tr>

I've checked and I have both max post and max upload set to 96MB.

I'm using ONE.COM hosting, MyBB installation is at www.lucesensibile.it/forum .
Please help me, I'm running out of ideas...

Thanks!

Fabio
Reply
#2
Solved: 4 Years, 8 Months ago
You have changed these options in MyBB but what if your host has a limitation for post_max_size.
I will suggest you to ask your host to increase post_max_size , the info related to post_max_size should be present in Tools and Maintenance.
Reply
#3
Solved: 4 Years, 8 Months ago
I think I found the solution, maybe not that optimized but it's working.
On another post on the forum (https://community.mybb.com/post-1110889.html) I found an user that applied this, commenting this line of code on the file functions_image.php:

@ini_set("memory_limit", $memory_limit);

It's working perfectly now, it looks like a problem while generating the thumbnails of the uploaded image.
Maybe it's not the best solution, do you have another workaround that's not commenting a line?

Thanks!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)