Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved 500 Internal Server Error
#1
Not Solved
I seem to be getting a 500 Internal Server Error whenever an Admin attempts to either create a new forum/subforum or edit the permissions of a group.

I cannot work out why this is. What are possible steps that I can take to try and fix this problem?

Cheers,
Reply
#2
Not Solved
basically,
there could be two reasons for the server error

1. Mod_Security
I have temporarily disabled it and expected that it
would fix the issue. looks like it is not main cause

2. many user groups exist
when we make a new forum, its groups permissions
are not storing within allotted time. not yet traced
exact cause for it
Reply
#3
Not Solved
(09-13-2016, 03:24 PM).m. Wrote: basically,
there could be two reasons for the server error

1. Mod_Security
I have temporarily disabled it and expected that it
would fix the issue. looks like it is not main cause

2. many user groups exist
when we make a new forum, its groups permissions
are not storing within allotted time. not yet traced
exact cause for it

Have you checked the server logs .m.? I would imagine the request is timing out or the memory limit is being reached. This can happen when there's a very large number of groups and there's unfortunately not much that can be done to help except raising the limits.
Reply
#4
Not Solved
^ @ Euan, initially user had reported error log similar to below
[23-Aug-2016 04:00:52 UTC] PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in ~/public_html/forum/inc/class_datacache.php on line 112
I had tested creating a new forum a number of times; result was a blank page; but no error was logged !
Reply
#5
Not Solved
(09-23-2016, 05:42 PM).m. Wrote: ^ @ Euan, initially user had reported error log similar to below
[23-Aug-2016 04:00:52 UTC] PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in ~/public_html/forum/inc/class_datacache.php on line 112
I had tested creating a new forum a number of times; result was a blank page; but no error was logged !

Interesting. Is this a VPS server or shared hosting?

If it's a VPS, the PHP memory limit can be increased to see if that helps (try something like 50MB memory limit or even more). Once the limit is changed in the php.ini configuration, Apache will need to be restarted (or PHP-FPM if using PHP-FPM). Once restarted, try creating a forum again and see what happens.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)