Thread Rating:
  • 4 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] YourCode 2.1.3
#21
(2016-12-12, 01:50 PM)Dr_The_One Wrote: One more issue:
It interact with my items of New points means http://www.com/newpoints.php?action=shop...on=myitems
It show following error on top.

Thanks for the report.

I'm having trouble investigating the problem because the copy of NewPoints I downloaded doesn't have the same directory structure. I can't find the file inc/plugins/newpoints/newpoint_shop.php

Are you using a different copy?
[retired]
#22
(2016-12-12, 05:56 PM)Wildcard Wrote:
(2016-12-12, 01:50 PM)Dr_The_One Wrote: One more issue:
It interact with my items of New points means http://www.com/newpoints.php?action=shop...on=myitems
It show following error on top.

Thanks for the report.

I'm having trouble investigating the problem because the copy of NewPoints I downloaded doesn't have the same directory structure. I can't find the file inc/plugins/newpoints/newpoint_shop.php

Are you using a different copy?

actually he is using mybb shop plugin link is here http://forums.mybb-plugins.com/Thread-Shop-1-8
#23
Okay I see issue, Dr_The_One, generally the parser object ($parser) is a global variable, but in this NewPoints plugin it is a variable local to the calling function.

I can introduce a small change in my plugin code to make the error go away, but it won't allow YourCode to do its work.

You can either ask the plugin author to edit the code or you can edit the plugin yourself.

Change:
function newpoints_shop_page()
{
	global $mybb, $db, $lang, $cache, $theme, $header, $templates, $plugins, $headerinclude, $footer, $options, $inline_errors;

To:
function newpoints_shop_page()
{
	global $mybb, $db, $lang, $cache, $theme, $header, $templates, $plugins, $headerinclude, $footer, $options, $inline_errors, $parser;

I'll get a fix ready for the bug, but that is all I can do from my end.
[retired]
#24
Thanks wildcard for fix .
Thanks a lot.
Repped for it.
#25
You are very welcome. Smile

Thank you so much for reporting issues and being patient with me.
[retired]
#26
YourCode 2.0.4 Released

Fixed:
  • broken images in ACP before install
  • error when parser is not valid

To upgrade just overwrite the existing files.
[retired]
#27
Not working with PHP 7.

After enter to the thread I see communication about preg_replace is not supported.

<error>
	<dateline>1482403665</dateline>
	<script>inc/class_parser.php</script>
	<line>440</line>
	<type>2</type>
	<friendly_type>Warning</friendly_type>
	<message>preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead</message>
</error>
#28
(2016-12-22, 10:55 AM)Hewret Wrote: Not working with PHP 7.

After enter to the thread I see communication about preg_replace is not supported.

Thanks for the report. I'll look into it when I can.
[retired]
#29
Hey Wildcard, I am testing this plugin in my clone forum currently.

I added all of my Mycodes, I plan to import all of them to my actual forum once I solve the problem with spoiler code from post #2.

I was using Spoiler MyCode plugin earlier and it had spoiler.css file which I could change to stylize, is there a way to make that code use that spoiler.css codes like spoiler_header and spoiler_body? Currently YourCode spoiler looks very bad in my forum (probably because I use custom theme and those colors simply look bad) but I was also experiencing title with Turkish characters issue (I am unable to write title with turkish character in it such as ş or ğ, if I use those then spoiler code doesnt work) so I would like to use YourCode spoiler but I need to be stylize it.

Also the one without title doesn't work for me for some reason, it doesn't open when I click and table codes break my forum. I can send image of how they break (or show it via link from discord) so you can investigate if you want.
#30
Sorry you are having problems. Let me take a look at both of the mentioned YourCode packs and I'll get back with you.
[retired]


Forum Jump:


Users browsing this thread: 1 Guest(s)