Thread Rating:
  • 4 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Advanced Sidebox 3.1.19
(2019-01-11, 09:17 AM)vk_knight Wrote: Now, how can I add adsense or similar type of ad codes in the custom boxes?

In any situation, just add the content into the custom box and any JavaScript into the headerinclude template. I don't use ads, but there shouldn't be an issue.
Alright, thanks.
Edited image posting fail. Replaced by actual image/mod

[Image: 2oFPAx9.png]

On a fresh install upon attempting to install and activate.
(2019-01-22, 10:44 AM)VIrusKing Wrote: On a fresh install upon attempting to install and activate.

I fixed your image for you.

That error indicates that a table is missing when side boxes are being deleted. I don't understand why we would be deleting side boxes at install, though.

Are you installing on a live forum? If so, send me some temp credentials. I won't get home until about twelve more hours, but I will take a look then.
Advanced Sidebox 3.1.17 Released

You can now edit each user's side box display preference in ACP if you have already upgraded to 1.8.20

If you are still using 1.8.19, everything will still work the same, but you won't get the added feature until after you update your forum.

Changes:
  • you can now change individual user's "Show Sideboxes" preference in ACP
Fixes:
  • a bug where the bad word filter was not applied to post contents in the Recent Posts module

To upgrade: Deactivate in ACP; overwrite the existing files; and activate.
is there no ready scripts for sideboxes? or i installed it wrong?
(2019-02-28, 02:06 PM)ITurkishmapping Wrote: is there no ready scripts for sideboxes? or i installed it wrong?

Try uninstalling and reinstalling. For some reason the scripts aren't populated sometimes.
Curious does this version correct the script definition? Only ask as a heads up for you because I noticed when updating one of my localhosts last night that had asb previous version installed due to a support question I helped with regarding it  in the past that it was now advising on said future issue eventually occurring with future php and this script not being defined

Quote:Message

Use of undefined constant THIS_SCRIPT - assumed 'THIS_SCRIPT' (this will throw an error in a future version of PHP)

Advanced Sidebox (3.1.16)
MyBB Version 1.8.20
PHP Version 7.2.4
SQL Engine MySQLi 5.7.21

You clearly will know more than I on the subject and your plugin of course, but, I ran into such a similar  issue while updating a plugin in the past and using something like defining the unknown:


if(!defined('THIS_SCRIPT'))
{
define('THIS_SCRIPT', 'unknown');
}


or wrapping like so:


if(THIS_SCRIPT=='asb-blah-blah-example.php')
{
 ...plugin coding here...
}

seemed to sort it out.
I don't remember hearing this before. Sorry if I did. Can you make an issue on GitHub so I will be sure to address it?

Thanks.
Hello Wildcard, thanks again for the excellent plug-in...

I just updated to .17 from .10...

I have been using both left and right sidebars next to each other in index in my mobile theme and PREVIOUSLY the sideboxes would load and then resize to fit the rest of the page

With this version they load and stay at the size they loaded at, which expands the rest of the page out past the content...

Any simple fix for this?
   

EDIT: I had to go back all the way to Build #4 to get it to behave as I needed, with the boxes re-sizing to fit the page. Whatever it was that changed between build #4 and #5 appears to be the difference.


Forum Jump:


Users browsing this thread: 1 Guest(s)