Thread Rating:
  • 4 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Advanced Sidebox 3.1.19
Hi,

First of all, thank you for the great plugin.

I am facing an issue. When i try to add anything in the sidebar, i get a warning. I am using PHP version 7.3. Due to this, I am not able to add anything in the sidebar.

Warning [2] "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? - Line: 125 - File: inc/plugins/asb/classes/StorableObject010000.php PHP 7.3.1 (Linux)

File Line Function
/inc/plugins/asb.php 45 errorHandler->error
/inc/plugins/asb.php 45 require_once
[PHP] asbClassAutoload
/inc/plugins/asb/classes/SideboxObject.php 10 spl_autoload_call
/inc/plugins/asb.php 45 require_once
[PHP] asbClassAutoload
/inc/plugins/asb/acp.php 220 spl_autoload_call
/inc/plugins/asb/acp.php 62 asb_admin_edit_box
/inc/class_plugins.php 142 asb_admin
/admin/index.php 819 pluginSystem->run_hooks
Got the same problems as above on PHP 7.3 so we had to roll it back to 7.2
(2019-04-22, 03:48 PM)Metallix Wrote: Got the same problems as above on PHP 7.3 so we had to roll it back to 7.2

I can't do that. My other sites are running on the same server with 7.3. So I will have to test the other sites again if I change it to 7.2. It will be a little painful to do that.
I am aware of the problem, just haven't had time to fix it. I will try to get it done some time this week. It is related to this closed issue on one of my helper classes:

StorableObject: PHP 7.3.3 Warning

I'm really sorry. I'll patch it when I can find time.

If you are in a bind, you can just download the latest copy of the StorableObject class here:

https://github.com/WildcardSearch/MyBB-Helper-Classes


Edit: Sorry, that won't work because of internal references. My bad.
(2019-04-22, 07:29 PM)Wildcard Wrote: I am aware of the problem, just haven't had time to fix it. I will try to get it done some time this week. It is related to this closed issue on one of my helper classes:

StorableObject: PHP 7.3.3 Warning

I'm really sorry. I'll patch it when I can find time.

If you are in a bind, you can just download the latest copy of the StorableObject class here:

https://github.com/WildcardSearch/MyBB-Helper-Classes


Edit: Sorry, that won't work because of internal references. My bad.

Thanks Mate. Really appreciate this.
Advanced Sidebox 3.1.18 Released

@maheshp & @Metallix

Fixes:
  • PHP Warnings when saving new side boxes
  • PHP Errors when THIS_SCRIPT is undefined
Changes:
  • Upgrade PortableObject Class

To upgrade: Deactivate in ACP; overwrite existing files; activate again.
Thanks Mate. Tested it and is working just perfect. Thanks a lot for fixing it so quickly. :-)

Also, I made some changes so that the sidebars are stacked up below the Boards on small screens so as to make them more responsive.

In asb_begin template:

Replace
          <td width="auto" valign="top">
with
          <td width="auto" valign="top" class="myCustomClass">

In asb_sidebox_column template:

Replace
          <td style="width: {$width}px;{$show_column}" id="{$column_id}" valign="top" >
with
          <td style="width: {$width}px;{$show_column}" id="{$column_id}" valign="top" class="myCustomClass">


And in my Global.css
@media (max-width: 991.98px) {
            .myCustomClass{
                      width:100%!important;
                      float:left;
            }
}

I hope this is the correct way. This is my first MyBB project so trying to follow the best practices.
(2019-04-24, 04:42 AM)maheshp Wrote: Thanks Mate. Tested it and is working just perfect. Thanks a lot for fixing it so quickly. :-)

You're welcome. Smile

(2019-04-24, 04:42 AM)maheshp Wrote: Also, I made some changes so that the sidebars are stacked up below the Boards on small screens so as to make them more responsive.

Great work. If I ever have any time, I am going to try to update ASB to be more responsive.
i'm having problems adding new boxes on Admin P, when I move the module, it just go back yo the modules list and never sticks to any column. How can I fix that?
[Image: 40DS6Te.png]

(2019-04-25, 01:25 PM)alv4 Wrote: i'm having problems adding new boxes on Admin P

Did you mean Admin CP or an ACP theme named "Admin P"?

(2019-04-25, 01:25 PM)alv4 Wrote: when I move the module, it just go back yo the modules list and never sticks to any column. How can I fix that?

That sounds like some JavaScript issue. Send me some temp admin credentials and I can look in about 4 hours.


Forum Jump:


Users browsing this thread: 1 Guest(s)