Solved: 4 Years, 8 Months, 2 Weeks ago [General] SSL and mixed content with external avatars
#1
Solved: 4 Years, 8 Months, 2 Weeks ago
I have SSL on my forum working fine, except when users have external avatar images hosted on an http-only url. 

At first I thought maybe there's a way for me to get the forum to download and host the avatars instead, but then I thought how users sometimes embed images into posts, which would incur the same issue, and while my users don't embed images very often, it's a potential problem and I'm not sure I want it to download every image. 

Perhaps this is just an inherent problem with using SSL on a forum, and I should be content that it will work without warnings on login pages etc?
Reply
#2
Solved: 4 Years, 8 Months, 2 Weeks ago
You should consider using https://community.mybb.com/mods.php?action=view&pid=450 which will help with mixed content serves over http

Owner and operator of Creators Wave
Reply
#3
Solved: 4 Years, 8 Months, 2 Weeks ago
(2016-11-05, 10:28 PM)katos Wrote: You should consider using https://community.mybb.com/mods.php?action=view&pid=450 which will help with mixed content serves over http

And pair that with a camo (https://github.com/atmos/camo) server to proxy content to get a setup that's like what is running here. This also has the secondary benefit of stopping sites from grabbing user IPs from hotlinked images.
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)