Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved MyBB where it shouldn't be:how to remove?
#1
Not Solved
For some strange reason I have a MyBB forum on a sub-domain. I have only ever had a link from this domain but now, typing in the web address for my web site takes me to a MyBB forum page. I have just deleted the forum in MySQL and when trying to get to my web site I get an error message - because the forum is now deleted.

I have tried a full up-load/publish to the new server on 2 occasions but still get the forum page. I have not republished the site since deleting the MySQL but I would like some explanation as to how this has happened and what I should do if it happens again. The only thing different/changed recently is that my hosts have changed server. 

Thank you.
Reply
#2
Not Solved
I used to do this ALL the time on accident, what I would do was accidentally mistake the FTP with my WinRar and end up moving (copying) all files from one directory to another.

The best thing to do to fix it is to go to the subdirectory that you don't want the forum in, select all items, and delete them. Simple as that.

And you should not have deleted the database... Your main forum is connected to that database, since you deleted that database, the main forum or sub forum can not pull the data that is being requested.


How to fix:

If you have a Database backup, go to phpMyAdmin and import it, then relink everything in the config.php and settings.php files.

If you don't have a backup, you've lost all your data - just create a new database and relink and start over.
www.volvl.com | Get your first month of hosting for $0.01 USD with Promo Code: Hexeus
[Image: 12946833.gif]


Reply
#3
Not Solved
(11-23-2016, 05:17 PM)Zaqre Wrote: I used to do this ALL the time on accident, what I would do was accidentally mistake the FTP with my WinRar and end up moving (copying) all files from one directory to another.

The best thing to do to fix it is to go to the subdirectory that you don't want the forum in, select all items, and delete them. Simple as that.

And you should not have deleted the database... Your main forum is connected to that database, since you deleted that database, the main forum or sub forum can not pull the data that is being requested.


How to fix:

If you have a Database backup, go to phpMyAdmin and import it, then relink everything in the config.php and settings.php files.

If you don't have a backup, you've lost all your data - just create a new database and relink and start over.

(11-23-2016, 05:17 PM)Zaqre Wrote: I used to do this ALL the time on accident, what I would do was accidentally mistake the FTP with my WinRar and end up moving (copying) all files from one directory to another.

The best thing to do to fix it is to go to the subdirectory that you don't want the forum in, select all items, and delete them. Simple as that.

And you should not have deleted the database... Your main forum is connected to that database, since you deleted that database, the main forum or sub forum can not pull the data that is being requested.


How to fix:

If you have a Database backup, go to phpMyAdmin and import it, then relink everything in the config.php and settings.php files.

If you don't have a backup, you've lost all your data - just create a new database and relink and start over.
Thank you for your reply. I don't want the forum which is why I have deleted it - so not a problem there. As far as I can see, I have deleted the files so am I right to assume that if I upload the site again, all should be OK?
Reply
#4
Not Solved
Let me say this:

If you delete all the files in the sub-domain but kept the database, you will have errors due to not having the site in the sub-domain.

If you delete the only database that you have, but kept the files, you will get errors saying missing "bla bla bla"

If you deleted the sub-domain files, and kept the main domain files, but deleted the database, you will have errors saying no database and missing "bla bla bla"

If you deleted the sub-domain files, kept the main domain files, and deleted a database NOT linked to the main domain, you will be fine.


-----------------------------------------

If you upload files, you need to go into settings.php and config.php and edit those settings to match the domain and database information.

If you plan on getting a NEW forum, I highly suggest downloading a fresh copy of MyBB 1.8.8 and install it manually, meaning follow their installation process to insure you have minimal to zero errors.
www.volvl.com | Get your first month of hosting for $0.01 USD with Promo Code: Hexeus
[Image: 12946833.gif]


Reply
#5
Not Solved
I have tried to upload the site again and still get the error message -  as attached - since I have deleted MySQL. The strange thing is that the forum was on a different sub domain - it had nothing to do with this site other than a link.  As in my last reply, I do not want the forum and I have also deleted the sub-domain.


Attached Files Thumbnail(s)
   
Reply
#6
Not Solved
FTP -> Your Site -> Inc -> config.php -> Edit (I suggest using Notepad++) -> Fill in your database settings.
www.volvl.com | Get your first month of hosting for $0.01 USD with Promo Code: Hexeus
[Image: 12946833.gif]


Reply
#7
Not Solved
(11-23-2016, 07:59 PM)Zaqre Wrote: FTP -> Your Site -> Inc -> config.php -> Edit (I suggest using Notepad++) -> Fill in your database settings.

Thank you for your reply but I'm a bit lost! FTP to my site and configure PHP - that should be OK. Using notepad  and fill in database settings, I need a bit more info!  Also, what am I configuring? I have deleted anything to do with the forum addon/MySQL/links.

Apologies, I can work through most things (eventually) it's the tec language and confidence to take another step into the unknown!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)