Not Solved [Mail] Cannot use smtp server
#1
Not Solved
I have an smtp server, which I can access through mozilla thunderbird with no problems. but when I try sending a verification email I get the message "The mail server is not ready, it did not respond with a 220 status message." In the email error log. Any way around or through this?

Using 1.8

When I telnet into it, I get [Image: 919fae56748d4cc18547556e8648bda9.png]
Which is clearly a 220, what am I doing wrong?
Reply
#2
Not Solved
It looks like you're hosting a machine with Godaddy. This does not look like a MyBB issue -- but more of a host issue. This post describes a similar issue with the same host:

http://stackoverflow.com/questions/30852...-transport

You may need to change the SMTP port to 587? At worst, you probably need to open a ticket up with Godaddy support.
Founder of Surreal, proud MyBB user for 8 years!
Website | Forums
Reply
#3
Not Solved
(2016-12-24, 01:33 AM)Downfall Wrote: It looks like you're hosting a machine with Godaddy. This does not look like a MyBB issue -- but more of a host issue. This post describes a similar issue with the same host:

http://stackoverflow.com/questions/30852...-transport

You may need to change the SMTP port to 587? At worst, you probably need to open a ticket up with Godaddy support.

I have it set on 587, still nothing, I will try godaddy support.

Okay so I've figured it out, and I have no idea how to fix it, but in smtp.php, in function get_data(), the $string variable does not carry any value. I have copy pasted some code and tried it on a different file, and it all works, it's only this function which fails, any way to fix this?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)