Jump to the post that solved this thread.
Solved: 5 Years, 8 Months, 3 Weeks ago Where can I have the Icons for Private Messaging?
#1
Solved: 5 Years, 8 Months, 3 Weeks ago
Hello guys,
On a old forums I used to see Post Icons for private messaging. Where can I have that on my forums?

It's like this but sending a private message with an icon next to it.
[Image: N46Cuwf.png]
Reply
#2
Solved: 5 Years, 8 Months, 3 Weeks ago
The only version of 1.8 that I use is 1.8.9.
I can't see any control panel settings to enable or disable post icons in private messages.
However, if the template is modified, they could be dropped there.
Look for {$posticons} present in private_send template.
On my unmodified default, it's line 39.

Also, check that you actually have post icons stored.
If they are available in newthread, editpost, and newreply, then they're on the system.

Add or delete specific icons in Admin CP / Configuration and click the link on the left side panel.
Reply
#3
Solved: 5 Years, 8 Months, 3 Weeks ago
(2017-01-06, 02:27 AM)HLFadmin Wrote: The only version of 1.8 that I use is 1.8.9.
I can't see any control panel settings to enable or disable post icons in private messages.
However, if the template is modified, they could be dropped there.
Look for {$posticons} present in private_send template.
On my unmodified default, it's line 39.

Also, check that you actually have post icons stored.
If they are available in newthread, editpost, and newreply, then they're on the system.

Add or delete specific icons in Admin CP / Configuration and click the link on the left side panel.

Here Post icon is there already : http://i.imgur.com/zAxn8fz.png
So what to do now
My post icons are also stored.
Reply
#4
Solved: 5 Years, 8 Months, 3 Weeks ago
Several things to look for.
1. Old forum may have used GIF files for post icons. Depending on how you upgraded, you may have the same icons, but stored as PNG files, while theme is still calling for non-existent GIF.
2. For the theme, check what the Image Directory is set to.
3. Does Default theme also have missing post icons?
4. You showed a screenshot of what it's supposed to look like. Show a screenshot of what it is actually displaying. Choose the entire compose area for the private message.
5. Are post icons available when creating new thread, editing existing post, and creating new post reply?
Reply
#5
Solved: 5 Years, 8 Months, 3 Weeks ago
(2017-01-07, 01:01 AM)HLFadmin Wrote: Several things to look for.
1. Old forum may have used GIF files for post icons. Depending on how you upgraded, you may have the same icons, but stored as PNG files, while theme is still calling for non-existent GIF.
2. For the theme, check what the Image Directory is set to.
3. Does Default theme also have missing post icons?
4. You showed a screenshot of what it's supposed to look like. Show a screenshot of what it is actually displaying. Choose the entire compose area for the private message.
5. Are post icons available when creating new thread, editing existing post, and creating new post reply?
The post icons are available when creating a new thread and new post, but not for Private messaging.
Reply
#6
Solved: 5 Years, 8 Months, 3 Weeks ago
1. Are you using default theme, or a modified upgraded theme?
2. Have you switched to the default theme and gotten the same results?
3. Create a new theme, name it TestTheme and base it off MyBB Master Style. Use that theme, then see if that works.

The new theme should have image directory setting "images" (no quotes)
If that doesn't work, it will require someone to go in with admin permissions to check to see what's wrong.
Reply
#7
Solved: 5 Years, 8 Months, 3 Weeks ago
(2017-01-08, 11:34 PM)HLFadmin Wrote: 1. Are you using default theme, or a modified upgraded theme?
2. Have you switched to the default theme and gotten the same results?
3. Create a new theme, name it TestTheme and base it off MyBB Master Style. Use that theme, then see if that works.

The new theme should have image directory setting "images" (no quotes)
If that doesn't work, it will require someone to go in with admin permissions to check to see what's wrong.

[Image: WBzluFC.png]
Yes it does show for the default theme! Just not with the new theme!!! Help pleaseee!!! Big Grin
Reply
#8
Solved: 5 Years, 8 Months, 3 Weeks ago
Export theme that isn't working properly and post the xml file. You may need to rename it to add .txt extension.
Reply
#9
Solved: 5 Years, 8 Months, 3 Weeks ago
I got it working by myself!!! It's resolved. Basicly just copy paste the Default template to your other theme into Private messaging template!!
Reply
#10
Solved: 5 Years, 8 Months, 3 Weeks ago
(2017-01-08, 11:34 PM)HLFadmin Wrote: 1. Are you using default theme, or a modified upgraded theme?
2. Have you switched to the default theme and gotten the same results?
3. Create a new theme, name it TestTheme and base it off MyBB Master Style. Use that theme, then see if that works.

The new theme should have image directory setting "images" (no quotes)
If that doesn't work, it will require someone to go in with admin permissions to check to see what's wrong.

Thanks.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)