Jump to the post that solved this thread.
Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 2 Years, 8 Months, 2 Weeks ago Problems uploading image files to forum
#21
Solved: 2 Years, 8 Months, 2 Weeks ago
Thanks Matt. I'll go back again to them. There must be someone at One.com who can understand what is going on. Really don't want to move hosts but if I have to so be it.
Reply
#22
Solved: 2 Years, 8 Months, 2 Weeks ago
I think what might help is to not sell it to them as being an issue with specifically uploading images, just give them the fatal error message and say you want your memory limit increased from 2MB to 32MB. You could have a huge 3000x2000 JPEG that needed less than 2MB of memory to process and it would work fine, or a 300x300 PNG that needed more and it would break, it just happens the sizes you've found are where they start to cross the 2MB memory usage limit, but would also happen if you wanted to run an importer or generate a large file or something - it's a common issue with hosting companies where once you say something specific with a certain application is breaking, they'll point to the application, but the cause is still something server side that just happens to only affect one specific thing. 2MB is just far too low to have this setting (the default is actually 128MB, I thought it was 32MB, so 2 is ridiculous).
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#23
Solved: 2 Years, 8 Months, 2 Weeks ago
Sadly One.com technical support seem to be ignoring the error messages I sent them and are adamant the problem lies with the dimensions of image files that are uploaded. They think that MyBB is causing the issue and is rejecting images files over certain dimensions! I didn't think that was even possible with MyBB.

I said the issue is a 2 MB memory limit. They replied that the limit is currently 96 MB. I then asked then why the error message referring to 2 MB. Unfortunately, this fell on deaf ears.

My only option now is to move hosts. Can you recommend an alternative hosting company via PM that I can use Matt?
Reply
#24
Solved: 2 Years, 8 Months, 2 Weeks ago
Thank you master Matt. I have same provlem but my hosting is kloud51 .com . I think it is server problem.
Reply
#25
Solved: 2 Years, 8 Months, 2 Weeks ago
It's been a while since I've used a hosting company, but Dreamhost were still decent the last I heard.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#26
Solved: 2 Years, 8 Months, 2 Weeks ago
Thanks Matt for the pointer.

By the way, One.com were still insisting that their php memory limit was set at 512 MB and I must admit it looks that way from the MyBB advanced debug information which does show that memory limit. Very weird. Strange thing is my son has a MyBB forum running with One.com and he has no issues at all.
Reply
#27
Solved: 2 Years, 8 Months, 2 Weeks ago
Hm, it did have a weird value (it wasn't in the usual format in the php.ini file), but the script was still erroring at a much lower value, so still doesn't explain why it was erroring in the first place; you'd get the same error if you used the same code outside of MyBB, it's not anything MyBB specific, was just using PHP built in image functions.

In fact, are the FTP details you sent me still active, and would you mind me using them again? Let me put a test script up on your site, totally separate to MyBB, and get them to explain why it errors.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#28
Solved: 2 Years, 8 Months, 2 Weeks ago
Hi Matt,

My forum website is finally up and running nicely at long last! Must have been a server issue as I have no problems at all with my new host which is Hi Hosting - I can thoroughly recommend them. As for One.com...well I think their support peeps need some serious PHP training.

Thanks again for all your help. Much appreciated.

Adrian.
Reply
#29
Solved: 2 Years, 8 Months, 2 Weeks ago
I've been using one.com for years and am not very keen on changing host.

However, I'm having the exact same issue. Attaching a zip or gz file, that doesn't exceed the size limit (2MB in my case) causes no problem. But attaching images far smaller in size than 2 MB (let's say 25kB) causes a blank screen. I tried uploading a 64x64 pixel png less than 1kB in size, and that actually worked, but that's about it.

I just installed MyBB and don't use any custom plugins of any kind, it's an install as fresh as one can be.

I used to run an SMF forum on the same site, and it didn't have any problems with image attachments. Not saying that SMF is better, of course, just pointing out that it's ... weird Smile
Reply
#30
Solved: 2 Years, 8 Months, 2 Weeks ago
^ have you checked latest entries of server error log to trace cause for the blank screen ?
if you are confused about it then please contact your web host support to check it & help ..
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)