[Duplicate] The message is too long. Please enter a message shorter than 9 characters
#1
Hi

This error is displayed when new postings.
The message is too long. Please enter a message shorter than 9 characters 

mybb version  1.8.10

upgraded from 1.8.9

just admin user can add post and all users can send just words < 6 character
Reply
#2
This is due to a known bug - when you use the 'show all settings' link, and save settings, some get set to 9. The setting values will need to be reset on a setting-group basis I'm afraid until we push a fix.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#3
my language board is not english
where can I see 'show all settings' link ?

too, I commented this code and it solved
datahandlers/post.php 265 line

$this->set_error("message_too_long", array($mybb->settings['maxmessagelength'], strlen($post['message'])));
return false;
Reply
#4
The 'show all settings' link is in the ACP on the list of settings groups, you will have already used it if you're having this issue. The proper way to fix is to re-set the settings values to the correct value, rather than commenting out code, as other settings will be affected.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#5
ok
I change Maximum Message Length to 1000
thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)