Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [General] No Style after fresh install 1.8.10
#11
Not Solved
This is the current htaccess file in the folder.
Options -MultiViews +FollowSymlinks -Indexes


#
# If mod_security is enabled, attempt to disable it.

# - Note, this will work on the majority of hosts but on

#   MediaTemple, it is known to cause random Internal Server

#   errors. For MediaTemple, please remove the block below

#
<IfModule mod_security.c>
	
# Turn off mod_security filtering.
	
SecFilterEngine Off

	
# The below probably isn't needed, but better safe than sorry.
	
SecFilterScanPOST Off
</IfModule>


#
# MyBB "search engine friendly" URL rewrites

# - Note, for these to work with MyBB please make sure you have

#   the setting enabled in the Admin CP and you have this file

#   named .htaccess
#
<IfModule mod_rewrite.c>
	
RewriteEngine on
	
RewriteRule ^forum-([0-9]+)\.html$ forumdisplay.php?fid=$1 [L,QSA]
	
RewriteRule ^forum-([0-9]+)-page-([0-9]+)\.html$ forumdisplay.php?fid=$1&page=$2 [L,QSA]

	
RewriteRule ^thread-([0-9]+)\.html$ showthread.php?tid=$1 [L,QSA]
	
RewriteRule ^thread-([0-9]+)-page-([0-9]+)\.html$ showthread.php?tid=$1&page=$2 [L,QSA]
	
RewriteRule ^thread-([0-9]+)-lastpost\.html$ showthread.php?tid=$1&action=lastpost [L,QSA]
	
RewriteRule ^thread-([0-9]+)-nextnewest\.html$ showthread.php?tid=$1&action=nextnewest [L,QSA]
	
RewriteRule ^thread-([0-9]+)-nextoldest\.html$ showthread.php?tid=$1&action=nextoldest [L,QSA]
	
RewriteRule ^thread-([0-9]+)-newpost\.html$ showthread.php?tid=$1&action=newpost [L,QSA]
	
RewriteRule ^thread-([0-9]+)-post-([0-9]+)\.html$ showthread.php?tid=$1&pid=$2 [L,QSA]

	
RewriteRule ^post-([0-9]+)\.html$ showthread.php?pid=$1 [L,QSA]

	
RewriteRule ^announcement-([0-9]+)\.html$ announcements.php?aid=$1 [L,QSA]

	
RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

	
RewriteRule ^calendar-([0-9]+)\.html$ calendar.php?calendar=$1 [L,QSA]
	
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)\.html$ calendar.php?calendar=$1&year=$2&month=$3 [L,QSA]
	
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)-day-([0-9]+)\.html$ calendar.php?action=dayview&calendar=$1&year=$2&month=$3&day=$4 [L,QSA]
	
RewriteRule ^calendar-([0-9]+)-week-(n?[0-9]+)\.html$ calendar.php?action=weekview&calendar=$1&week=$2 [L,QSA]

	
RewriteRule ^event-([0-9]+)\.html$ calendar.php?action=event&eid=$1 [L,QSA]

	
<IfModule mod_env.c>
		
SetEnv SEO_SUPPORT 1
	
</IfModule>
</IfModule>


#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to

# the client faster.

#
<IfModule mod_deflate.c>
	
AddOutputFilterByType DEFLATE text/css text/html application/xhtml+xml text/xml application/xml text/plain text/x-component application/javascript application/x-javascript application/rss+xml application/atom+xml application/json application/manifest+json application/x-web-app-manifest+json application/vnd.ms-fontobject application/font-sfnt application/font-woff application/font-woff2 image/svg+xml image/x-icon
</IfModule>


# Note: You are able to choose a different name in the Admin CP. If you've done that you need to change it here too

<Files "error.log">
	
Order Deny,Allow
	
Deny from all
</Files>

Error logging is currently disabled with my webhost, so I have no logs.
Reply
#12
Not Solved
Please rename your .htaccess on server root to htacess.txt and refresh your forum page (ctrl + F5)
Greetings Sven (ps: Sorry for my bad english!!)

My plugins - [email protected]
Reply
#13
Not Solved
Nothing has changed with the renaming of the file.
Reply
#14
Not Solved
What happend when you set the cache to 0777.
All the folders inside chache to 0777 and all files to 0644?
Cache 0777
cache/themes 0777
cache/themes/x {where X is  all folders inside ) 0777
And all files include the files in all folders to 0644.

When i check your site, the cache folder and .css files return a 403 forbidden error to me.


Failed to load resource: the server responded with a status of 403 (Forbidden)
http://karmarp.com/forums/cache/themes/theme2/css3.css Failed to load resource: the server responded with a status of 403 (Forbidden)
http://karmarp.com/forums/cache/themes/t..._black.css Failed to load resource: the server responded with a status of 403 (Forbidden)
global.css Failed to load resource: the server responded with a status of 403 (Forbidden)
css3.css Failed to load resource: the server responded with a status of 403 (Forbidden)
Reply
#15
Not Solved
Unless adding the 0 in front of everything makes everything change, I have all the directories set to 777 and all the files to 666, they were previously 755 and 644.
Reply
#16
Not Solved
644 for files is the correct setting.
777 is the correct setting for all the folders.
Don't know how you set it ( via cpanel, directadmin or ftp ).
But some setting is still blocking access to those files and shows your site as is now.

Maybe you can give MATT FTP acces to your site, and he can help you a little better then reply and wait.
Reply
#17
Not Solved
Yeah I'm stumped then, might be easier to take a look myself if possible.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#18
Not Solved
Sure I'll pm you the login.
Reply
#19
Not Solved
Okay, I think I've fixed it, but have no idea how.

I created a folder called "cachetest" and put a test file in this folder, which I was able to access. I then moved all the files from ./cache/ into ./cachetest/, renamed the original ./cache/ folder to ./cache_/, and renamed my new ./cachetest/ folder to ./cache/ (basically swapping them over), and suddenly the theme worked fine. Now, however, I can't delete the ./cache_/ folder. I don't know how but it's almost like this specific folder is corrupted somehow, wouldn't allow access to file inside it and now can't be deleted. Very strange.

You also had some missing files for your theme, so I've uploaded these, and it now looks like it should Smile
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#20
Not Solved
The same problem happens to me.
I'm building a new site with mybb1.8.12 , everything brand new .
it shows cache/themes/theme1/global.css 404 error.

Im already follow this guildline
https://docs.mybb.com/1.8/install/

if i used http for install, the page goes right.
if i used https for install, the page goes "cache/themes/theme2/css3.css " error.

if i used http for install,  the page goes right.
if i used https for install, the page goes "cache/themes/theme2/css3.css "  error.

if i used http for install,  the page goes right.
if i used https for install, the page goes "cache/themes/theme2/css3.css "  error.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)