Solved: 4 Years, 1 Month, 4 Weeks ago Subforum read/unread inconsistencies
#1
Solved: 4 Years, 1 Month, 4 Weeks ago
Hi,

In the Archives, I found 2 posts by guys who reported the problem I have today.

Post 1

Post 2

Quote:How to reproduce:
If you have new posts in a subforum, go into it, read them, return to the frontpage. The toplevel forum should be read, too. But returning to the frontpage shows again the icon for unread posts. Now enter the forum again. Nothing new in there. So again return to the frontpage without doing anything. Now the icon changed to no new posts. Thought of a cache problem, but this happens only with forums that have childs.

In 2008, at the time of 1.4.2,  Ryand Gordon, Ex-Lead MyBB Developer said:

Quote:This is by design - You will see the problem in other forum software too. It's simply because it'd be too processor intensive to calculate all of the children forum and parent forums for every single second level and third level forum on the index

In 2009, following a user's suggestion, he said here:

Quote:...that might be a decent idea. I think it should go into 1.6 though.

Today I have MyBB 1.8.10 and the (annoying issue) is still here.

Any help would be much appreciated.

PS: A couple of years ago, I knew a guy who had this problem on phpBB and solved it by tweaking the permissions but I do not know what de did exactly, besides phpBB is another forum software. But that might be a hint.
Lightbulb Want to hide, remove or disable some MyBB features without editing code or installing a pluging? Read my tutorial
Reply
#2
Solved: 4 Years, 1 Month, 4 Weeks ago
If somebody is ever interested by this topic, the solution is:

ACP > Configuration > Board Settings > Forum Display Options > Attempt to Mark Parent Forums as Read = Yes
Lightbulb Want to hide, remove or disable some MyBB features without editing code or installing a pluging? Read my tutorial
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)