Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [How To?] SSL problems
#1
Not Solved
Need help or a solution to get images to load or show after ssl (https) install. No png,jpg,bmp,gif etc. mybb 1.8
https://www.copdonline.net/Forum/
Thanks very much.
Reply
#2
Not Solved
Did you change your board url to https:// ?
Also check if there are any url related to images inside Theme css or template which contains http.

I will also suggest you to create a filter which replaces http:// to https:/

Regards
WallBB
Reply
#3
Not Solved
thanks for your response.........
board urls were changed to https

What is the or how is this filter made?
thanks
Reply
#4
Not Solved
(03-17-2017, 05:37 AM)copd Wrote: thanks for your response.........
board urls were changed to https

What is the or how is this filter made?
thanks

Try this in your .htaccess file

RewriteEngine On 
RewriteCond %{HTTP_HOST} ^copdonline\.net [NC]
RewriteCond %{SERVER_PORT} 80 
RewriteRule ^(.*)$ https://copdonline.net/$1 [R,L]
.m.  Very helpful staff member, very knowledgeable.
Reply
#5
Not Solved
Thanks for the help but still no luck getting images to load on either the forum pages or html pages.
https://www.copdonline.net/Forum/
installed DMZ plugin......no change
board urls set to https
edited htacces file numerous times.......no success
here is current htaccess

RewriteEngine On
RewriteCond %{HTTP_HOST} ^copdonline\.net [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://copdonline.net/$1 [R,L]
# Use PHP5.4 Single php.ini as default
# Changed PHP handler from

application/x-httpd-php54s to application/x-httpd-phpbetas on Wed

Dec 16 19:18:58 MST 2015.
AddHandler application/x-httpd-phpbetas

.php
# Original
# If you modify this file then change the above line

to: # Modified
<IfModule mod_rewrite.c>
RewriteEngine On
#

Certain hosts may require the following line.
# If vanilla is in

a subfolder then you need to specify it after the /.
# (ex. You

put Vanilla in /forum so change the next line to: RewriteBase

/forum)
# RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-d


RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$

index.php\?p=$1 [QSA,L]
</IfModule>

RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://copdonline.net/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://copdonline.net$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.copdonline.net/.*$

[NC]
RewriteCond %{HTTP_REFERER} !^http://www.copdonline.net$

[NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]



any help or suggestions most appreciated
Reply
#6
Not Solved
“Failed to load resource: the server responded with a status of 403 (Forbidden)”

Check your permissions. You may need to chmod your image folder.
Reply
#7
Not Solved
This user has been denied support. This user has been denied support.
chmod all to 777 then change url to right one and try again if it doesnt work reinstall forum.
edit: nvm pictures are back.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)