Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Subscription Issues
#1
Not Solved
My forum is experiencing weird subscription-related bugs since I opened it. I have multiple threads in this forum about those issues and so far I got no solution at all.

Threads I opened on this issue (highest is the newest) Hopefully this will be my last thread on this issue and in this thread I will try to explain what's going on. 

I opened my forum in July 2015, my first issue with subscription is October 2015 when my users started to report me that, they get private message notifications with another user's username, we couldn't understand what's going on and in which pattern, so we couldn't reproduce. Weird thing is this issue - unlike others I will explain here - is either fixed or simply not happening anymore for some reason. 

Then users started to report that they are getting private message notifications on threads, they didn't subscribed to. I am almost positive that this issue still persists and I often can see it happening to my account, to my understanding moderators were causing this issue, since I am admin I have multiple Index/Archive threads which needs to be updated, and often updated by moderators and I see my subscription preference for those threads changing to moderators' own subscription preference when they edit my thread. Therefore in my last thread I talked about it, even though other bug I talked about in that thread got resolved, this one we still couldn't.

Another interesting issue I am facing with subscriptions is that some people get subscription private messages in English language, rather than my forum's own language. I have a suspicion that if user didn't actually subscribed to that thread himself and he is getting that private message notification because of bug, he gets private message in English language.  But again, since I can't understand the pattern, I can't reproduce it therefore I can't confirm it.

Even though I talk about 'private messages' a lot, I doubt that this issue is related to only private message preference. I think for some reason my forum is messing up peoples' subscriptions but it's mostly noticeable when someone actually gets private messages in forum. I even thought of removing entire private message notification mechanic from my forum and created thread about asking how to do that, which I got no reply.

I am very amateur on this forum software etc stuff but I am sure that I didn't use any plugin, related to subscriptions and I didn't do any change - even though I am facing quite a lot issues - on MyBB core files especially the one related to subscriptions.

Any help would be appreciated.

Softaculous Theory
  • I opened my forum in July 2015, when I opened it my forum was 1.8.5 and I was using Softaculous in cPanel to update my forum, I also used it when I installed my forum and I didn't know that it can be harmful. After some point, strangely version of my forum changed and I opened this thread: 1.8.5 Forum Became 1.8.4. First thread about subscription notification anomalies started in October, which means I also used Softaculous when I updated my forum to 1.8.6 (in September 2015), using it to update 1.8.6 might be the cause of this bug.
Reply
#2
Not Solved
This might be caused if your host aggressively caches certain things. To narrow down the causes try these steps first.

Have you done a file verification check recently? ACP->Tools & Maintenance->File Verification. List any files that show up as Changed or Missing.

Does this also happen if you have all Plugins disabled? ACP->Settings->General Settings. Disable all Plugins set to Yes.
Reply
#3
Not Solved
Hello dragonexpert,

I almost periodically check these things, only important (php) files shown in verification are member.php and functions.php. When I look at it I see that functions.php change is caused by not me - but Google SEO plugin. member.php modifications are caused by Patches plugin and my 'simplify registration' focused changes in Patches plugin.

I think subscription related stuffs are in usercp.php and when I compare difference between my usercp.php and freshly downloaded MyBB, there's no difference at all.

Since I don't know exact pattern, I can't exactly reproduce it and try to see if it happens or it stops under certain conditions. Things I exactly know are following:
  1. There are users, getting private message notifications in English language for no reason. 
  2. There are users, getting private message notifications on threads they didn't subscribed to that way.
  3. My subscription preference for threads I created (threads that need to be updated periodically) changes when any other moderator does any change. I don't notice it directly but when I look at my subscriptions I see that I have private message notification is set on that thread and then I look at that thread and see that thread is recently edited by a moderator with that preference.
  4. There were users, getting private message notifications on some other username's name, but that's not happening anymore for some reason.
I was also experiencing very bad caching issue and I actually have thread about that too: Caching Issue

Basically for some reason, when I have too high server load value shown in my forum (which is about 20+) users, looking at same page were seeing those pages as first requested user. Since it's not static content, but it's a forum with different settings and most importantly username of user is shown that page, people were thinking that they actually switch to another users' account. When I experienced this issue I was in Small - Shared server in my hosting company.

Before that I had an issue with my htaccess file I thought that the issue I am facing might be related to my mistake there. But apparently it wasn't. I tried to talk to my hosting company to solve this issue and they kept saying that they don't do any caching. So I actually had to move to better server (more expensive - actually it's even Business but still Shared and I still use like %5 of space I am paying for) to see if this will stop. After I moved I think only encountered this issue once, after that it entirely stopped happening. 

So maybe users' not getting private message notifications with someone elses' username issue stopping might be related to me switching server.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)