Thread Rating:
  • 4 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] DVZ Hash 1.2
#1
The first pure-plugin solution introducing modern password hash functions to MyBB.
Changes implemented with MyBB 1.8.9 and 1.8.11 (#2498, #2649) allow to take over the process of creating and verifying passwords, allowing DVZ Hash to run without any core modifications.

Extend MyBB → DVZ Hash


Version 1.0
-----BEGIN PGP SIGNATURE-----
 
 iQEcBAABCAAGBQJY7BPcAAoJEOL9rFzOOKd9P4AH/Aq7l5Z6ylwFoN23++kCMQJk
 3wZQAL0vS0dyC4rFuzmEdhIU2PnLLn9G2ez4jx/wJq2pWhxiOpoP+u5sQeK9B0GI
 Yh5k74SzErKJHlVk26qfNuh9ZN32QhfJBQuWG8Eev0HUyvYM3kS+asphDUs3TYPb
 E4DfGhXZc6BNDfscD4eVHVOxCjb0IvBc4ausPDUYSP5rEuSIma8OUlAGuFc2pziL
 DRK4EHrJt0IWDc2MPd+IBgJ6z3JAjGbiHgzZBLLx27dByJu2FLeM2l3jwvCt1fPH
 MCeXQGgurS3cMY1H8tWkOoFZZ9/AKeMha5fjWdOSZ6fOKsvMQz2dDxFa3Jkxrpk=
 =zXzx
 -----END PGP SIGNATURE-----
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#2
Thank you, I have been waiting for this really long time. I didnt want to use any core modifications due to issues with updating to newer versions of MyBB.

Is there anyone who use this? I dont wanna be the first one. Is it compatible with social login plugins (MyFacebook connect, etc)?
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#3
(04-11-2017, 01:55 PM)Eldenroot Wrote: Is it compatible with social login plugins (MyFacebook connect, etc)?

It should be - social media login plugins generally bypass the password check.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#4
"Selected password hash algorithms cannot be wrapped. "
http://prntscr.com/ev82ol

..idk...i have php version 7.1.3 and 1.8.11 mybb

now i can't uninstall the plugin  Undecided
An authorization code mismatch occurred. Please confirm that you wish to perform the action below.
Reply
#5
(04-11-2017, 06:00 PM)AlexanderPep Wrote: "Selected password hash algorithms cannot be wrapped. "
http://prntscr.com/ev82ol

I've pushed changes to 3 files - it should work correctly after overwriting them: https://github.com/Devilshakerz/mybb-dvz...54413ae2e4

Quote:now i can't uninstall the plugin  Undecided
An authorization code mismatch occurred. Please confirm that you wish to perform the action below.

Did that occur after the confirmation (Yes button)? Fixed a related issue as well: https://github.com/Devilshakerz/mybb-dvz...b2fd06a13d
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#6
(04-11-2017, 06:00 PM)AlexanderPep Wrote: "Selected password hash algorithms cannot be wrapped. "
http://prntscr.com/ev82ol

..idk...i have php version 7.1.3 and 1.8.11 mybb

now i can't uninstall the plugin  Undecided
An authorization code mismatch occurred. Please confirm that you wish to perform the action below.

Let us know if it is fine with the new version. I will try the plugin next week after things will be sorted out (my testing board is outdated and I dont have enough brave to test it on my live forum with 2k users registered Sad)
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#7
Why is not default in mybb core to start off with like phpbb
Reply
#8
Because bcrypt doesn't work properly with PHP versions less than 5.3.7, and MyBB 1.8 supports PHP 5.2.
Reply
#9
What does it do exactly?
Reply
#10
Really thanks for giving this out dude .
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)