Not Solved Activation email not sending
#1
Not Solved
(Yeah, I know I posted one already but no response)

So, activation emails are not sending.
I've done a test with the following code:

<?php
 error_reporting(E_ALL);
$to = '[email protected]';
if(mail($to, 'Testing mail', 'This is a mailing test to see if PHP mail works.'))
{
echo 'Mail was sent by PHP';
}
else
{
echo 'PHP could not send the mail';
print_r(error_get_last());
}
?>

The email worked without receiving any errors
Any ideas on a fix for this??

Incase it's needed; website: https://nexonnetworks.co.uk
Reply
#2
Not Solved
you can use php handler at the mail settings (Configuration section in forum admin panel)
and put [email protected] as admin email at the Site Details page of Configuration
Reply
#3
Not Solved
I put it as the site email, however it seemed to not work?
Reply
#4
Not Solved
can you share your mail settings from ACP?
[Image: cafaf18ba2.gif]
FileSquid is under development
[Image: trk1]
Reply
#5
Not Solved
I have had this exact same issue now for several years, on all of my various forums that I have setup (all using GoDaddy servers).

The test php works

<?php
 error_reporting(E_ALL);
$to = 'sale[email protected]';
if(mail($to, 'Testing mail', 'This is a mailing test to see if PHP mail works.'))
{
echo 'Mail was sent by PHP';
}
else
{
echo 'PHP could not send the mail';
print_r(error_get_last());
}
?>

It shows as "Mail was sent by PHP" and I do get the email sent to the account (note: email address above was altered to prevent spam!)

So, PHP works but I can create a new login account and no activation email arrives, and requesting to have the activation email re-sent also appears to go through but the email is never received.

I have absolutely NOTHING in the System Mail log (under T&M).

I have tried everything off and on for a couple of years.  Is there anyway to fix this?

I did have to add PHP.PHP to the /inc/mailhandlers/ folder because there is not one included with any version of MyBB (at least from 1.6 on up).  Is there some version of PHP.PHP that should be used?  I mean, it seems to work if invoking the code above, just not through MyBB.

Any ideas?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)