Not Solved [JavaScript] Multiquote not working.
#1
Not Solved
Hey guys.

I have revamped my postbit completely. Its just HTML/CSS changes.

However the quick edit button and the multi quote button do not function.

The errors shown in the console are :

general.js?ver=1807:531 Uncaught ReferenceError: cookieSecureFlag is not defined
    at Object.set (general.js?ver=1807:531)
    at Object.multiQuote (thread.js?ver=1804:82)
    at HTMLAnchorElement.onclick (VM1002 showthread.php?tid=1&pid=51:742)
VM1002 showthread.php?tid=1&pid=51:1 Uncaught SyntaxError: Unexpected end of JSON input
    at JSON.parse (<anonymous>)
    at Function.m.parseJSON (jquery.js?ver=1806:5)
    at Object.multiQuotedLoaded (thread.js?ver=1804:116)
    at Object.complete (thread.js?ver=1804:99)
    at j (jquery.js?ver=1806:2)
    at Object.fireWith (jquery.js?ver=1806:2)
    at x (jquery.js?ver=1806:5)
    at XMLHttpRequest.b (jquery.js?ver=1806:5)

I have no idea what that means. Can anyone explain?
Reply
#2
Not Solved
what is your forum url & exactly which version of MyBB you are using ?
basically, code in headerinclude template of your theme needs to be updated.
see this & this
Reply
#3
Not Solved
(2017-04-28, 10:41 AM).m. Wrote: what is your forum url & exactly which version of MyBB you are using ?
basically, code in headerinclude template of your theme needs to be updated.
see this & this
Thanks for the help. The multi quote button is fixed now, However the quick edit still won't work. Maybe its because I have changed the complete layout of postbit?

https://gyazo.com/c58e654164b7d696beaecb7cb7bbb620

Do you want me to post the code of postbit?
Reply
#4
Not Solved
^ provide test user account & forum url so that someone can check it
Reply
#5
Not Solved
Sent you a PM with details.

Problem solved.

Thanks to MyBB for their wonderful help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)