Not Solved Console Error Messages jQuery is not defined
#1
Not Solved
I am getting a lot of jQuery is not defined error messages in my console when I go to my Admin CP to perform any task.
This is causing a high page load time which should be instant on localhost.


My Console Error Messages:


GET localhost/jscripts/jquery.js 522 ()
jquery.plugins.min.js:1 Uncaught ReferenceError: jQuery is not defined
    at jquery.plugins.min.js:1
(anonymous) @ jquery.plugins.min.js:1


general.js?ver=1810:125 Uncaught ReferenceError: jQuery is not defined
    at general.js?ver=1810:125
(anonymous) @ general.js?ver=1810:125


admincp.js:5 Uncaught ReferenceError: $ is not defined
    at admincp.js:5
(anonymous) @ admincp.js:5


tabs.js:1 Uncaught ReferenceError: $ is not defined
    at tabs.js:1
(anonymous) @ tabs.js:1


index.php?module=tools-recount_rebuild:16 GET localhost/admin/jscripts/jqueryui/css/redmond/jquery-ui.theme.min.css 
jquery-ui.min.js?ver=1804:6 Uncaught ReferenceError: jQuery is not defined
    at jquery-ui.min.js?ver=1804:6
    at jquery-ui.min.js?ver=1804:6
(anonymous) @ jquery-ui.min.js?ver=1804:6
(anonymous) @ jquery-ui.min.js?ver=1804:6

index.php?module=tools-recount_rebuild:86 Uncaught ReferenceError: $ is not defined
    at index.php?module=tools-recount_rebuild:86
(anonymous) @ index.php?module=tools-recount_rebuild:86
Reply
#2
Not Solved
what is your forum url ?
Reply
#3
Not Solved
(2017-04-30, 01:33 PM).m. Wrote: what is your forum url ?

I'm running it on localhost
Reply
#4
Not Solved
can you post content of your headerinclude template (in php tags)
Reply
#5
Not Solved
Do you have jquery.js in jscripts folder?
My Projects - Support My Projects

Don't forget to rate posts!
Reply
#6
Not Solved
If you use XThreads plugin -> update it to the latest GITHUB version, if not then there is another issue
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#7
Not Solved
(2017-05-01, 11:14 AM).m. Wrote: can you post content of your headerinclude template (in php tags)

I don't know if it will make sense but in ACP none of the options buttons will drop down for me and when I checked headerinclude here is what I see, I am using a 1.6 MyBB theme Natpen if thats the problem, but it shouldn't affect ACP templates right? All templates I try it shows this blank screen.

[Image: babc930cd0e2eae05ebee9595d06bf2e.png]


(2017-05-01, 11:31 AM)chack1172 Wrote: Do you have jquery.js in jscripts folder?

Yes, I do.

(2017-05-01, 03:49 PM)Eldenroot Wrote: If you use XThreads plugin -> update it to the latest GITHUB version, if not then there is another issue

I don't use the plugin.
Reply
#8
Not Solved
which version of MyBB you are trying ?
basically you have to check MyBB functionality with its stock (default) theme
if you have to experiment with a new theme then its better to use a compatible theme.
Reply
#9
Not Solved
(2017-05-01, 04:45 PM).m. Wrote: which version of MyBB you are trying ?
basically you have to check MyBB functionality with its stock (default) theme
if you have to experiment with a new theme then its better to use a compatible theme.

I am running MyBB 1.8.11, tried using default theme and it's still the same.
Should I download a fresh MyBB 1.8.11 and upload it? because I upgraded this forum from 1.8.2 to 1.8.11
Reply
#10
Not Solved
forum admin panel >> preferences >> Turn on / off Code Mirror --> toggle the selection & save preferences.
does the code in templates become visible now ? if so, post content of headerinclude template
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)