Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Smf2 > Mybb
#1
Not Solved
Hello,

While using merge system and running tasks, all goes fine until it comes to forum converting, when i start that task it stops with this message:

Quote:MyBB has experienced an internal SQL error and cannot continue.
SQL Error:1366 - Incorrect integer value: '' for column 'pid' at row 1Query:INSERT INTO mybb_forums (`import_fid`,`name`,`description`,`import_pid`,`disporder`,`linkto`,`lastpost`,`parentlist`,`lastposter`,`lastposttid`,`lastposteruid`,`lastpostsubject`,`threads`,`posts`,`type`,`active`,`open`,`allowhtml`,`allowmycode`,`allowsmilies`,`allowimgcode`,`allowvideocode`,`allowpicons`,`allowtratings`,`usepostcounts`,`usethreadcounts`,`password`,`showinjump`,`style`,`overridestyle`,`rulestype`,`rules`,`unapprovedthreads`,`unapprovedposts`,`defaultdatecut`,`defaultsortby`,`defaultsortorder`,`pid`) VALUES (21,'Staff Discussion / General','General stuff',0,54,'',0,'','',0,0,'',0,0,'f',1,1,0,1,1,1,'1',1,1,1,1,'',1,0,0,0,'',0,0,0,'','','')
Please contact the MyBB Group for technical support.

Any help?
Reply
#2
Not Solved
are you using local server or live web server for the conversion ?
local server is preferred.

if possible disable strict mode of MySQL server and try merge process again ..
Reply
#3
Not Solved
I am using a web host, with cpanel.
Reply
#4
Not Solved
can you try using SQL query given in method 2 here & check what system says ..

if you succeed in changing the MySQL Strict Mode then you can try again merge process ..
Reply
#5
Not Solved
I dont have SUPER privileges for that.

I have however asked my host for that.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)