Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 1 Month, 5 Days ago Error in mybb 1.8.13
#1
Solved: 1 Month, 5 Days ago
hello

i have upgrade to mybb 1.8.13

but i am still find problem like 1.8.12

[Image: exsj2ewCTnKbEFlweRQ_sw.jpg]

[Image: IH2MIGipShSjY-P913Kd-A.jpg]

how to fix it?
[Image: b7fb400675fc4b678f836ff8ab111259.jpg]  
Reply
#2
Solved: 1 Month, 5 Days ago
does it also happen to MyBB's stock theme ?

looks like code in templates need updating.
upgrading guidance Wrote:Visit your Admin Control Panel, then go to Templates & Style > Templates > Find Updated Templates.
This will show you a list of all the templates that have changed during the upgrade.

You can either revert these templates to their default - meaning all the changes you've made to it will be removed
- or you can see a Diff Report which will show you exactly what's changed. If you have a custom theme installed,
it is probably best that you look at the Diff Report and apply the changes you need.
Reply
#3
Solved: 1 Month, 5 Days ago
i don't know this is same issue or not

after i choose Diff Report in index_boardstats

my login pop up move to left bottom side

[Image: wJs8gOUqSIqHFErob1seSQ.jpg]
[Image: b7fb400675fc4b678f836ff8ab111259.jpg]  
Reply
#4
Solved: 1 Month, 5 Days ago
modifying index_boardstats template should have no affect on the position of login popup.
have you taken backup of the theme before editing its templates ?
Reply
#5
Solved: 1 Month, 5 Days ago
Happening to me also. With the default template, login will pop up in the bottom left corner of the page now. Need to clear the cache to get this.

i.e. things that pops up in a new window (login or my alerts) works. But if I click shift-reload.. They are added to the bottom left corner now.

edit: No problems in community.mybb.com even after I cleared the cache (login pops up in it's own window).

edit2: Pop up works again if I revert default template's global.css file. Not sure how to get my forum theme to work though.
Reply
#6
Solved: 1 Month, 5 Days ago
^ Thank You Smile
with MyBB 1.8.13 release announcement, we have a note saying that theme’s CSS files might need updating
however at present could not get what exactly needs to be changed & where ..

modal related css in the global.css (after /** jGrowl End **/)
PHP Code:
/** Modal Start **/

.blocker {
    
positionfixed;
    
top0;
    
right0;
    
bottom0;
    
left0;
    
width100%;
    
height100%;
    
overflowauto;
    
z-index9999;
    
padding20px;
    
box-sizingborder-box;
    
background-colorrgb(0,0,0);
    
background-colorrgba(0,0,0,0.75);
    
text-aligncenter;
}

.
blocker:before{
    
content"";
    
displayinline-block;
    
height100%;
    
vertical-alignmiddle;
    
margin-right: -0.05em;
}

.
blocker.behind {
    
background-colortransparent;
}

.
modal {
    
width400px;
    
text-alignleft;
    
background#fff;
    
displayinline-block;
    
vertical-alignmiddle;
    
positionrelative;
    
z-index2;
    -
webkit-box-sizingborder-box;
    -
moz-box-sizingborder-box;
    
box-sizingborder-box;
    -
webkit-border-radius8px;
    -
moz-border-radius8px;
    -
o-border-radius8px;
    -
ms-border-radius8px;
    
border-radius8px;
    -
webkit-box-shadow0 0 10px #000;
    
-moz-box-shadow0 0 10px #000;
    
-o-box-shadow0 0 10px #000;
    
-ms-box-shadow0 0 10px #000;
    
box-shadow0 0 10px #000;
}

.
modal a.close-modal {
    
positionabsolute;
    
top: -12.5px;
    
right: -12.5px;
    
displayblock;
    
width30px;
    
height30px;
    
text-indent: -9999px;
    
backgroundurl(images/close.pngno-repeat 0 0;
}

.
modal-spinner {
    
displaynone;
    
width64px;
    
height64px;
    
positionfixed;
    
top50%;
    
left50%;
    
margin-right: -32px;
    
margin-top: -32px;
    
backgroundurl(images/spinner_big.gifno-repeat center center;
    -
webkit-border-radius8px;
    -
moz-border-radius8px;
    -
o-border-radius8px;
    -
ms-border-radius8px;
    
border-radius8px;
}

/** Modal End **/ 
Reply
#7
Solved: 1 Month, 5 Days ago
(11-08-2017, 11:20 AM).m. Wrote: modifying index_boardstats template should have no affect on the position of login popup.
have you taken backup of the theme before editing its templates ?
Hi .m.

After the upgrade, looks like default global.css is missing the modal block (from /** Modal Start **/ to /** Modal End **/). This is the reason for the login window problem. The default template can be fixed by reverting it. 

But folks with custom templates can copy that block to the themes' global.css. Once done MyAlerts and Login will work again (tested only with w3-responsive so YMMV).

Edit: Missed it by that much.  Big Grin Thanks .m. Smile
Reply
#8
Solved: 1 Month, 5 Days ago
^ Thank You for tracing the CSS code Smile
Reply
#9
Solved: 1 Month, 5 Days ago
can you help me
how to fix it?

i don't understand
[Image: b7fb400675fc4b678f836ff8ab111259.jpg]  
Reply
#10
Solved: 1 Month, 5 Days ago
1. Go to "Templates & Style"
2. Click on the theme you want to edit
3. Click global.css "Option" button
4. Click 'Edit Style'
5. Click "Edit Styleshee: Advanced Mode"
6. Copy and paste the modal start code block (from post #6) to the end of the global.css
7. Click 'Save Changes & Close'

And if you do shift-F5, pop up should work now.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)