Not Solved [How To?] SMTP Emails....
#1
Not Solved
Hello MyBB,


I have a problem here which I had years ago.. Somehow I managed to get it working when I used windows live mail (When hosted on a VM) but now that its not on a VM and I'm running windows 10, I have the new version of windows mail and I am unable to send emails anymore.

All my settings on my GMail are working, I also installed outlook on here to text you the sending and receiving smtp and it does send and receive them when it runs it's test. 

When I use the settings on MyBB it does not send anything?

I am curious as to what I need to send emails on my computer. Do I need some kind of server or just need the ports open and I enter the smtp details on the ACP? I can't find any tutorials explaining everything on this issue, any help would be appreciated.

Playing around with the ports I manage to get one of 2 error messages.

1- Unable to connect to the mail server with the given details. Reason: 0:
2- The mail server is not ready, it did not respond with a 220 status message.

UPDATE: On my VM I reopened it and tried it on that forum in which after a bit of playing around with started working again. Tried the same off of my VM (Even keeping WLM open on the VM, still getting error 0

UPDATE 2: WLM was useless, now years later I find out I dont need it open to send mail. Still having issues off of my VM So I'm wondering if I'm missing some kind of file somewhere...

UPDATE 3: Temporarily fixed it... I checked my localhost/phpinfo.php and noticed smtp was on local host. Anyway, if this is an issue for anyone else simply go into your php.ini and fix the [mail function] to the smtp and port, that simple..

It sent one email now I get the same error


[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP=smtp.gmail.com
; http://php.net/smtp-port
smtp_port=465

Bumping.

I noticed that changing the code in the php.ini does change the smtp on phpinfo.php but at the same time on my VM the php.ini settings are at localhost and port 25 but are showing smtp.gmail.com and port 465 in the phpinfo.php?

Update 4: Copied the files from VM to my desktop kept it in C: just so the directories are the same, opened xampp up and MyBB, used the exact same email and pass as my VM (Which I did a test email am minute prior and it worked) and I get
Unable to connect to the mail server with the given details. Reason: 0:
Then on my VM I tested my second gmail in which I received the same error, so I went in WLM and added a new account (My new email) as a test and once it saved I retried a test email and it worked so WLM def does something weither it's open or not, I need my credentials in it so it sends on my VM! The port 465 and 993 is not open on my VM so I will be trying to close it on my desktop and try my new gmail on WLM on here and retest it all out.
Reply
#2
Not Solved
Still no luck... Any help?...
Reply
#3
Not Solved
I guess xampp comes with sendmail isn't it? then you only have to edit sendmail.ini located in XAMPP_direcotry/sendmail/
[Image: cafaf18ba2.gif]
FileSquid is under development
[Image: trk1]
Reply
#4
Not Solved
You should change the MyBB settings in the ACP to use SMTP to send email, rather than sendmail. You should then set the host, port, username, password etc. to the details required by your SMTP server. Editing the values in php.ini only affects the settings used when you use the PHP mail() function (the default setting for MyBB).

The settings can be found in ACP > Configuration > Mail Settings. You will need to change the actual setting values depending on the SMTP server (email host) that are using (I've included a screenshot of my settings for MailGun below). If you can tell us which SMTP host you are using, we might be able to help tell you what the settings need to be.

[Image: ezL14AZ.png]

Depending upon the actual SMTP service, you might also need to make sure the sender emails are the same as the login email. These can be set in ACP > Configuration > Site Details:
  • Admin Email
  • Return Email (if this is left blank, the Admin Email is used)
Reply
#5
Not Solved
(2017-11-22, 06:14 PM)Euan T Wrote: You should change the MyBB settings in the ACP to use SMTP to send email, rather than sendmail. You should then set the host, port, username, password etc. to the details required by your SMTP server. Editing the values in php.ini only affects the settings used when you use the PHP mail() function (the default setting for MyBB).

The settings can be found in ACP > Configuration > Mail Settings. You will need to change the actual setting values depending on the SMTP server (email host) that are using (I've included a screenshot of my settings for MailGun below). If you can tell us which SMTP host you are using, we might be able to help tell you what the settings need to be.

[Image: ezL14AZ.png]

Depending upon the actual SMTP service, you might also need to make sure the sender emails are the same as the login email. These can be set in ACP > Configuration > Site Details:
  • Admin Email
  • Return Email (if this is left blank, the Admin Email is used)

As I mentioned it is locally hosted so my confusion at this point is the SMTP server... Is the SMTP server my WLM or just gmail in general since I have it enabled? What exactly do I need to have running other than xampp for my STMP to send? I just did a fresh install of the newer xampp with a clean mybb, will try out the normal smtp setting but also editing the return email as you mentioned as I dont recal seeing those settings.

UPDATE: Does not work, same error: Unable to connect to the mail server with the given details. Reason: 0:

Is there a way to see more details of the issue like some error log with more info than unable to connect? Maybe that'll help me out a bit.

UPDATE2: Something was wrong with my original xampp and I was missing my sendmail folder. Anyway, long story short I'm just using phpmail for now. 

Closed.
Reply
#6
Not Solved
For future reference, the SMTP server would be the GMail server - smtp.gmail.com
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)