Not Solved Can't search usergroup in ACP
Not Solved Photo 
I updated to myBB 1.8.13 today and the only way I can search by usergroup is to go into groups on the left and select 'view users in this group' so I'm not sure if something broke during the update?

[Image: AmxpaLT.png]

Is there something that might have borked in the update or something I'm missing?
Not Solved
Are you sure there are users present in the usergroup you are looking for ?
I tried this on my board with MyBB 1.8.13 and it works fine.
Not Solved
Yea - I've double checked that I have the correct ones.  Something i've noticed is that if they were RECENTLY added to that group - IE they were added after we updated, they show up.. But if not, they don't.  

I have attempted to force change the groups of users from member/mod and back again but it won't work so I'm not entirely sure what's going on.  On site - they still show the correct permissions I just can't Search them.

[Image: Ya0Nqc5.png]

I searched Mods/Officers here - and it found nothing.  When I go to the groups on the left, and look at those groups:  
[Image: PoyCd6O.png]
[Image: 55qFame.png]

It shows that I have members in these groups.  It's like that with all of the groups.. but I'm.. kind of at a loss
Not Solved
I completely deleted all of my usergroups and started to rebuild them... And I'm having the same issue - The group shows members in it, but when I do a 'find users' by that membergroup it shows that none of them are a part of that group... I'd love to see if someone has any ideas lol
Not Solved
Any luck getting this one sorted? Works fine here.

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Not Solved
No - I haven't had any luck with searching by usergroup. It's almost acting like the usergroups themselves don't even appear in the ability to Query. I did a search with the only field being activity sorted by oldest and only got 60 something when I have 90+ accounts sorted into usergroups and none of those usergroup sorted accounts showed up in the list with the activity search.

I'm uncertain if I need to go digging through a php file or something and see if I borked up a setting somwhere, though I'm not sure what I would have done - especially since I have completely deleted and remade the usergroups..

Not Solved
Bit of a wild stab in the dark, but do you have caching enabled? If so, disable, clear the cache and try this again please?

Owner and operator of Creators Wave
Not Solved
(2017-12-26, 11:49 PM)katos Wrote: Bit of a wild stab in the dark, but do you have caching enabled? If so, disable, clear the cache and try this again please?

Cache has been cleared on everyones browsers, it has been rebuilt in the ACP as well. Cache is not the issue here, something else is happening. It's selecting users but not pulling them correctly.

I've helped Tabs a little bit tonight just to get some insight on the situation myself.

We have overwritten files with the 1.8.14 files taken directly from this site as well.

I do not know if this matters but all upgrades from past to current upgrade have been done through Softaculous. It created a MySQL table mybb_upgrade_data that was empty so we dropped it (after comparing it to one of my own MyBB installs that did not have that table in the SQL). Nothing changed. Empty table. Worthless drop that didn't really save space.

I'm not too sure what else Softaculous adds when upgrading but I do know it is a bit weird and not a preferred method.

Literally the only thing that does not work is searching.
> SELECT finger FROM hand WHERE id='3'
Not Solved
To add to this - we were digging around in the phpMyAdmin and discovered that somewhere along the way, I ended up having two different table prefixes for the database.   I appear to have an extra copy of everything.  The config.php is using the mybbct_ for the databases  and I have a mbb_  set of files that appears to have old content.  

There was a mbb_users  that only had 13 lines in it - where the mybbct_users had a couple hundred lines..  So we verified that the mbb_users had the same names as the mybbct list and dropped it to see if that would fix it. 

Spoiler alert        It didn't.   :|

We're not sure if we are safe to just drop these mbb files, or if we should try to merge them, or if we can just leave them well enough alone and they'll just kinda hang out .

What we did notice prior to dropping the old user file is that where before I could click groups -> Options ->List users to see all the users in the groups.. Now that doesn't work.  And up to that point, we had done nothing but compare files on my site to files on her site (that has a functioning search) so nothing was changed or edited... Sad

Edit  With further inspection, we have found that the mbb database appears to be super old - from when we were initially setting up the site back in February of 17.  So it looks like we can just delete these files and not miss anything - but I'm not sure

EDIT#2  we've deleted the old mbb database files after some deliberation and a LOT of backups.. and are still unable to use any part of the search function now (and weren't prior to these deletions).. And the browse users only returns 4 pages.    What we did notice is that after we did an optimization of the database through the ACP that the browse users stopped working.
Not Solved
assuming that your forum is eligible for the support [see support eligibility policy]
you may PM me temporary access to forum admin panel & your web host panel to check

Forum Jump:

Users browsing this thread: 1 Guest(s)