[Duplicate] COPPA Deny
#1
Currently on the register page if you have COPPA compliance in settings to "Deny users under the age of 13." They get an incorrect message on the page asking for Birthday.

Quote:In order to register on these forums, we require you to verify your age to comply with COPPA. Please enter your date of birth below.

If you are under the age of 13, parental permission must be obtained prior to registration. A parent or legal guardian will need to download, fill in and submit to us a completed copy of our COPPA Compliance & Permission form.
[color]

This is actually a very old issue but imho one worth noting.  The message should instead be:

"Due to COPPA requirements this forum has chosen to disallow all registrations from members under the age of 13. We still require for registration your birthdate in order to remain COPPA compliant.  You agree by submitting that your provided Date of Birth is accurate."
[/color]
But of course you change it to be suitable.
Reply
#2
Yep, seems to be part of the same issue I highlighted not too long ago. Don't know if it was ever fixed or not though. Good catch.

See: https://community.mybb.com/thread-206683.html

Edit: nope the issue still looks to be open: https://github.com/mybb/mybb/issues/2576
Reply
#3
This should be a relatively simple issue. I've added the "difficulty:easy" label to the GitHub issue and linked this thread.
Reply
#4
(2017-11-22, 06:00 PM)Euan T Wrote: This should be a relatively simple issue. I've added the "difficulty:easy" label to the GitHub issue and linked this thread.

I'll submit a PR tomorrow afternoon.
Reply
#5
(2017-11-23, 12:13 AM)kawaii Wrote: I'll submit a PR tomorrow afternoon.

Did this issue ever get fixed in GitHub? It looks to me like it's still open. I've patched our forum's 1.8.15 software to fix it because we needed the "Deny" feature to work properly - would be happy to work out how to send a PR so I can contribute back to MyBB if nobody else is working on this.
Reply
#6
No, the issue is still open unfortunately and we haven't received a patch yet.
Reply
#7
OK, have submitted a patch - if I've messed up or failed to adhere to standards in any way, please let me know. There wasn't much that needed to be changed - "difficulty:easy" was if anything an understatement!
Reply
#8
(2018-04-07, 06:01 AM)Laird Wrote: OK, have submitted a patch - if I've messed up or failed to adhere to standards in any way, please let me know. There wasn't much that needed to be changed - "difficulty:easy" was if anything an understatement!

Looks good to me, hanks. I just need to test it Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)