MyBB 1.9 Development
I know it's too early but I'm curious

This is my first contact whit twig

What will change in plugins system?

All plugins will must be rewritten?

Maybe sameone can post simple plugin for 1.9?
My Plugins

PM only paid support
Reply
(2021-01-11, 03:23 PM)Supryk Wrote: This is my first contact whit twig

https://github.com/mybb/mybb/blob/develo...hread.twig
as you can see in the link above, you can use conditional, loop etc in template.

(2021-01-11, 03:23 PM)Supryk Wrote: All plugins will must be rewritten?

If your plugin doesn't change the templates, then you probably don't need to make changes to make it compatible.

(2021-01-11, 03:23 PM)Supryk Wrote: Maybe sameone can post simple plugin for 1.9?

If you are saying about a plugin that makes changes to the template, then for now it is not possible to do it because the theme system is not ready. https://github.com/mybb/mybb/issues/3689
Reply
It will be my first time using Twig as well. I'm thinking that I at least maintain a 1.8 version of my plugins for at least 6 months after 1.9 series is released. I am hesitant on doing any more major plugins just because of all the changes that would need to be made for it to be 1.9 ready.
Reply
At this point I'd like to know what's the benefit of waiting for 1.9x vs switching to a software that's already responsive and has plugins ready to go?

Let's say you're a MyBB Admin and you have a site with plugins and custom template. When 1.9x comes out will you do the work to fix your templates and plugins? It's almost surely a similar amount of work to convert to another forum software.

Has anyone on the MyBB team really thought this out at this point?

btw, this thread is now over 3 years old. This just breaks my heart because I was really pushing to have 1.9x simply an update that incorporated a responsive theme by default and it's somehow been a much bigger update. One that is now really obvious more than the MyBB team can find time to accomplish.

Twig, Composer, Swiftmailer, Alerts, and Conversations are all additions almost no one cares about.

Twig is probably the only real upgrade requirement to help facilitate a responsive theme.

I'm sure my post will be considered discouraging. Well, I consider discouraging waiting over 5 years for a responsive theme by default.

Meh. Best of luck to the Admins who are waiting on this. Hope you're not holding your breathe.
Reply
Removed
Reply
For me 1.8 is customizable enough to be able to wait as long as you need ... I also know that it is not for everyone, it takes enough knowledge to make changes which makes many look for something ready.
I will not say that I will wait, I will simply continue with Mybb as long as security updates continue to be provided.
Personally, I am quite satisfied with the 1.8.
I am very grateful to the Mybb team for providing this software for free.
Reply
I would expect any user to stay with a software because of the sum of features it provides and how it is designed to be used by both admins, regular users, and anything in-between. I would not assume users pick any software solely nor primarily because of the upgrade or installation processes which are a short term issue, if at all.

It surely is to be considered seriously, yes. But do not miss reality; we are not (as of this moment) providing a software aimed to paid clients and thus we are not competing with software that do.

Quote:Unfortunately, I was told it was a waste of time because 1.9 would be released very soon so I never moved forward.

I'm sure there was a misunderstanding if these were the words the person who contacted you used.

The 1.9 theme is done. It might require some adjustments as we move forward finishing pending tasks, yes, but is scenically done. The theme isn't holding the project, that would be a more accurate description of why your offering was reviewed but surely kindly rejected.
Reply
I can't believe it's already 3 years since this thread started.
[Image: 40DS6Te.png]

Reply
Am I looking in the wrong place: https://github.com/mybb/mybb/projects/2
1.9 was last worked on 23 Jun 2020?
Reply
(2021-02-03, 03:10 PM)woostar Wrote: Am I looking in the wrong place: https://github.com/mybb/mybb/projects/2
1.9 was last worked on 23 Jun 2020?

1.9 won't be up-to-date on Github as the rebase is worked on locally so all changes will be applied at once. We are just finishing up on the rebase and we will be pushing all of the canges once the rebase is complete for the release of 1.8.25.
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply


Forum Jump:


Users browsing this thread: Furious, 1 Guest(s)