MyBB 1.9 Development
MyBB was never about money. Open source never was. It was, is always a free ride. I don't see anything wrong with it as long people appreciate the effort involved.
Reply
Github mybb:develop/1.9. hasn't been synced since 15 Nov 2020. Is there a latest build?
Reply
No. It's being rebased, and that can't be done practically live on the repository.
Reply
I think this version should be renamed to 2.0 in the beginning as 1.9 should have been out like a decade ago. It'll sound more new, more fresh and better than 1.9 in my honest opinion. People do care such things and I believe there'll be more attention to MyBB just because of this, even though it's something so small.
Reply
2.0 would suggest it's a major change in codebase, which it isn't, it's just an evolution of the 1.x branch. Version numbers aren't dictated by length of time between releases. If anything, after the issues we had in the past about 2.0 requiring all new plugins and themes, calling 1.9 2.0 would if anything make it sound like a larger upgrade than it is, and put people off upgrading to it.

Also we'd only released 1.6.3 a decade ago, 1.9 hasn't been in development quite that long!
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
Sorry, didn't mean to sound ignorant or salty about it because I exaggerated a bit. Technically speaking, indeed, you're absolutely right and it's even enough to keep the version number 1.9.x. I just wanted to tell my feelings towards it as MyBB for me is the best free forum software solution on the market and I literally used all of them, including some paid ones for over a decade. When I just think as a "costumer" or "consumer", I somehow thought that'd be better to rename it 2.0 even though it's not maybe quite right to do it techinacally, just because I think that'd make MyBB more popular and attract more people, that's all.

I know it'll worth the wait no matter what. My only wish that it has now more features that now provided through plugins, even "basic" ones. I wish all the best!
Reply
(2021-07-14, 10:03 AM)Matt Wrote: 2.0 would suggest it's a major change in the codebase, which it isn't, it's just an evolution of the 1.x branch. Version numbers aren't dictated by the length of time between releases. If anything, after the issues we had in the past about 2.0 requiring all new plugins and themes, calling 1.9 2.0 would if anything make it sound like a larger upgrade than it is, and put people off upgrading to it.

Also, we'd only released 1.6.3 a decade ago, 1.9 hasn't been in development quite that long!

so then it's possible to use the old themes from what I understand from the new 2.0 version?
[Image: PM8RRQ7.png]
Reply
free projects are hard to work with, mybb is the best forum to date but in my opinion it could offer paid services with themes and plugins so you can work full time and not just as a hobby.
in this way the project could develop well also in 2021 and not proceed slowly for years.
Reply
(2021-07-18, 12:27 PM)Wazzyl Wrote:
(2021-07-14, 10:03 AM)Matt Wrote: 2.0 would suggest it's a major change in the codebase, which it isn't, it's just an evolution of the 1.x branch. Version numbers aren't dictated by the length of time between releases. If anything, after the issues we had in the past about 2.0 requiring all new plugins and themes, calling 1.9 2.0 would if anything make it sound like a larger upgrade than it is, and put people off upgrading to it.

Also, we'd only released 1.6.3 a decade ago, 1.9 hasn't been in development quite that long!

so then it's possible to use the old themes from what I understand from the new 2.0 version?

Do you want say from 1.9 to 2.0 ?
Reply
(2021-07-18, 12:27 PM)Wazzyl Wrote:
(2021-07-14, 10:03 AM)Matt Wrote: 2.0 would suggest it's a major change in the codebase, which it isn't, it's just an evolution of the 1.x branch. Version numbers aren't dictated by the length of time between releases. If anything, after the issues we had in the past about 2.0 requiring all new plugins and themes, calling 1.9 2.0 would if anything make it sound like a larger upgrade than it is, and put people off upgrading to it.

Also, we'd only released 1.6.3 a decade ago, 1.9 hasn't been in development quite that long!

so then it's possible to use the old themes from what I understand from the new 2.0 version?

The next version is 1.9 not 2.0, and themes won’t be compatible as we are upgrading to a more modern template and styling system.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)