Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Unable to Edit Language Files Within the ACP
#1
I understand that translations can be done within the ACP thus making translation a bit easier. However I can only edit the default English language variables. I installed other languages and can not edit them the same way although they can be used in the forums. I installed the English(UK) pack from the extend section and it is editable from within the ACP. Apparently I am doing something wrong but I can't figure out what. Please help.
Reply
#2
languages folder , its subfolders & the files should be writable

basically php files of your language can be set with CHMOD 666

see files permissions
Reply
#3
I have double checked the permissions prior to posting. All files of all languages have the same permissions,666. The directories 755. Is there any chance that the ACP is not translated affects this? I see no reason why though.
The only language that I can edit is the EnglishGB which I downloaded from the extend section of the site. All other languages were downloaded from the translations subforums. And I installed them all exactly the same way setting the exact same permissions.
One odd thing is that when selecting edit language variables I don't see them, I get a, lets say, blank page, but if i click on Quick Phrases tab I get a warning message "Before you can edit the language file, you must CHMOD the files in this language set so that the server has permission to write to them." which does seem that the files are read only, but they are actually writeable and I can see the the text which can be edited, but when I edit nothing gets saved.
Reply
#4
what does tools & maintenance section in forum admin panel say about language files CHMOD settings ?
Reply
#5
All of the required files and directories have the proper CHMOD settings.
It says everything is writable.
Reply
#6
are you using Apache server or NGINX server ?
if it is Apache then the issue appears to be odd ..

would you like to PM me temporary access to forum admin panel & files (FTP) to check ..

or it would be better to setup a local server (eg. xampp) in your computer,
install MYBB and use it for your development work ..
Reply
#7
I am using the apache server on Debian stable
I also have MyBB set up in a VM and have the same issue.
Reply
#8
(02-09-2018, 12:29 PM)Prixtis Wrote: One odd thing is that when selecting edit language variables I don't see them, I get a, lets say, blank page, but if i click on Quick Phrases tab I get a warning message "Before you can edit the language file, you must CHMOD the files in this language set so that the server has permission to write to them." which does seem that the files are read only, but they are actually writeable and I can see the the text which can be edited, but when I edit nothing gets saved.

After doing a chmod 777 greek/admin
I am able to edit and save the Quick Phrases. Note I did a chmod 777 on the directory and not the files in it. The files were and still are 666.
I also did a chmod on the greek directory in case it would enable editing the frontend files, but no luck.

This thing really has got me scratching my head...
Reply
#9
^ have you checked the test forum provided through PM ?

basically a semi-colon is missing in a language file &
that affects files loading in forum admin panel !

datahandler_login.lang.php
$l['logindata_regimageinvalid'] = 'Ο κωδικός επαλήθευσης εικόνας που έχετε εισαγάγει δεν είναι σωστός. Παρακαλώ εισάγετε τον κωδικό ακριβώς όπως φαίνεται στην εικόνα.'

mistakes in using escape character (eg. \) also affect the loading
Reply
#10
Mr .m. you are a wizard!
There was a ";" missing at the end of the line. Everything loads fine now.
Thank you very much for your help and support
+1

PS I just rated you and your rating now is my birth year lol!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)