Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 1 Year, 8 Months, 2 Weeks ago Adding support for webp format
#1
Solved: 1 Year, 8 Months, 2 Weeks ago
I want to add .webp fotmat support to my uploads on my forum. img bbcode can handle this format but when i try to upload a .webp file as attachment mybb gives error and says its not a valid format. i tried to add it in acp (attachment settings) but nothing changed. 
you can see a webp image below if your browser supports.
  • WebP lossy support
    • Google Chrome (desktop) 17+
    • Google Chrome for Android version 25+
    • Opera 11.10+
    • Native web browser, Android 4.0+ (ICS)

  • [size=undefined]WebP lossy, lossless & alpha support[/size]
    • Google Chrome (desktop) 23+
    • Google Chrome for Android version 25+
    • Opera 12.10+
    • Native web browser, Android 4.2+ (JB-MR1)
    • Pale Moon 26+


  • [size=undefined]WebP Animation support[/size]
    • Google Chrome (desktop and Android) 32+
    • Opera 19+

[Image: 3boats.webp]

edit: img bbcode is not worked here but it works on my forum here: http://digiartreklam.com.tr/Marmaris-test-webp
Reply
#2
Solved: 1 Year, 8 Months, 2 Weeks ago
I was able to do it on my forum just fine. I used image/webp for mime type.
Reply
#3
Solved: 1 Year, 8 Months, 2 Weeks ago
I did it like this and not works for me 
   
Reply
#4
Solved: 1 Year, 8 Months, 2 Weeks ago
anyone?
Reply
#5
Solved: 1 Year, 8 Months, 2 Weeks ago
what exactly is not working ?
I've used exact settings of your screenshot & I could use webp files for attachments.
img tag also worked for the webp file on the Chrome browser & Chrome based browsers
Reply
#6
Solved: 1 Year, 8 Months, 2 Weeks ago
(03-15-2018, 08:43 AM).m. Wrote: what exactly is not working ?
I've used exact settings of your screenshot & I could use webp files for attachments.
img tag also worked for the webp file on the Chrome browser & Chrome based browsers

I can't add as attachments. What can be the reason?
Reply
#7
Solved: 1 Year, 8 Months, 2 Weeks ago
may be there is a problem with your web server.
if direct help required, you may PM me temporary access to files (FTP) & forum admin panel
Reply
#8
Solved: 1 Year, 8 Months, 2 Weeks ago
thank you .m.
My php version was couse it. I changed php version to 7.2 and it is working fine now. There are some errors about googleseo but they are not visible on front-end so not a big deal.
Reply
#9
Solved: 1 Year, 8 Months, 2 Weeks ago
I have done the setup above, but that makes WEBP files regular attachments like ZIP or RAR. Is there support for WebP as a full-rights image type like JPG/PNG (thumbnails generation, inclusion in <img> tags when the attachment is inserted in the post, etc...
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)