Not Solved Change URL into more friendly ones
#1
Not Solved
issue has been fixed
Reply
#2
Not Solved
This can easy be done using the Google SEO plugin.
Reply
#3
Not Solved
(2018-03-16, 08:23 PM)Brian. Wrote: This can easy be done using the Google SEO plugin.

I already have this plugin, can you please go into more detail?
Reply
#4
Not Solved
This can easily be configured in the plugin settings. I can't remember off the top of my head what the settings are.
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply
#5
Not Solved
(2018-03-16, 08:30 PM)Ben Wrote: This can easily be configured in the plugin settings. I can't remember off the top of my head what the settings are.

https://imgur.com/7eRQrnl


These are the settings, and also do I need to configure the .htaccess as well?
Reply
#6
Not Solved
would you be able to PM me an admin login? I haven't used this plugin in a while.
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply
#7
Not Solved
Moved to Plugin Support.
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply
#8
Not Solved
Make sure you set up and use the .htaccess file that comes with Google SEO the only two things you need to change is this 
RewriteRule ^([^&]*)&(.*)$ http://yoursite.com/MyBB/$1?$2 [L,QSA,R=301]

Change yoursite.com/MyBB to your domain.

# Some hosts need a RewriteBase specification.
RewriteBase /MyBB/

Replace MyBB with the folder you have MyBB installed in if it's in the root just put a /

Once all that is done make sure Google SEO is enabled by going to 

Admin CP -> Configurations -> Google SEO and enable all the options

Now go to

Admin CP -> Configurations -> Google SEO URL

go down until you see User URL scheme and replace that with 


{url}

I recommend you keep the
User-
in front of it.

Now go back to the .htaccess file and find

# Google SEO URL Users:
	RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

and remove
User-

Only remove this if you removed the User- from the step above if you didn't change it don't touch this.

Save.
Now go back to your plugins page and find Click to Apply changes to core files under the Google SEO plugin and click apply.
Reply
#9
Not Solved
(2018-03-16, 08:53 PM)Brian. Wrote: Make sure you set up and use the .htaccess file that comes with Google SEO the only two things you need to change is this 
RewriteRule ^([^&]*)&(.*)$ http://yoursite.com/MyBB/$1?$2 [L,QSA,R=301]

Change yoursite.com/MyBB to your domain.

# Some hosts need a RewriteBase specification.
RewriteBase /MyBB/

Replace MyBB with the folder you have MyBB installed in if it's in the root just put a /

Once all that is done make sure Google SEO is enabled by going to 

Admin CP -> Configurations -> Google SEO and enable all the options

Now go to

Admin CP -> Configurations -> Google SEO URL

go down until you see User URL scheme and replace that with 


{url}

I recommend you keep the
User-
in front of it.

Now go back to the .htaccess file and find

# Google SEO URL Users:
	RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

and remove
User-

Only remove this if you removed the User- from the step above if you didn't change it don't touch this.

Save.
Now go back to your plugins page and find Click to Apply changes to core files under the Google SEO plugin and click apply.

Thank you.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)