[Pushed] mycode_auto_url bug
#1
I mentioned this problem in a comment on GitHub pull request #2968, but here's a proper bug report.

This:

http://example1.com/ http://example2.com/ http://example3.com/

is the result of the MyCode:

[url]http://example1.com/[/url] http://example2.com/ [url]http://example3.com/[/url]


We would expect the URL for example2 to have been converted into a link, but it hasn't been (at least, not on the forum software as it is at time of posting).

This can be fixed by replacing each of the occurrences of

.*

in each of the regexes in mycode_auto_url() in inc/class_parser.php with:

[^\]]*
Reply
#2
Thank You for reporting. Developers will check it.
Reply
#3
We've had a lot of issues with the auto URL part - it was changes to that functionality in1.8.15 that broke videos in posts. We need to take another look and see if we can improve it.
Reply
#4
Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/3103

Thanks for contributing to MyBB!

Regards,
The MyBB Group
Reply
#5
Not only auto url or video, the parser itself needs a lot of improvement imo. I myself faced limitation while parsing few things (like rgba color).
But these all are waste of efforts till we decide a new editor. The parser has to be modified / re-written to suit that, I guess.
Reply
#6
(2018-04-08, 10:04 AM)effone Wrote: Not only auto url or video, the parser itself needs a lot of improvement imo. I myself faced limitation while parsing few things (like rgba color).
But these all are waste of efforts till we decide a new editor. The parser has to be modified / re-written to suit that, I guess.

I would certainly hope not! We can't change the MyCode structure witout breaking old posts.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)