Solved: 4 Years, 1 Month ago Updated PHP
#11
Solved: 4 Years, 1 Month ago
There are some data type casting and array offset issues with PHP 7.2+ which we are aware of and working on it. Anyone reporting such kind of issues will be highly appreciated.

Other than the mentioned issues there is no problem running MyBB with PHP 7.
Reply
#12
Solved: 4 Years, 1 Month ago
Tried PHP 7.1.18 and receive the same internal error as posted in OP.
Reply
#13
Solved: 4 Years, 1 Month ago
Disabled all plugins and tried to upgrade PHP again and STILL receive the same 'MyBB was unable to load the SQL extension.' error.
Reply
#14
Solved: 4 Years, 1 Month ago
So prior to upgrading, your forum works fine with the currently set Database credentials in inc/config.php? Are you using Shared Hosting or a server?
Plugin Count: I lost count.
Public Plugins are available here.
Please do not PM me for support unless asked to.
Reply
#15
Solved: 4 Years, 1 Month ago
(2018-07-07, 06:18 PM)Wires Wrote: So prior to upgrading, your forum works fine with the currently set Database credentials  in inc/config.php? Are you using Shared Hosting or a server?

Yep works perfectly fine on PHP 5 and I am using shared.
Reply
#16
Solved: 4 Years, 1 Month ago
Typically MYSQL/MySQLi comes as a PHP package rolled into one. What host are you using? I'd strongly suggest trying another host as it seems like PHP7-MySQL package isn't installed. To see the requirements read here. This isn't actually a MyBB problem.
Plugin Count: I lost count.
Public Plugins are available here.
Please do not PM me for support unless asked to.
Reply
#17
Solved: 4 Years, 1 Month ago
(2018-06-27, 08:51 PM)effone Wrote: MySQL extension is deprecated since PHP 5.5 and was removed in PHP 7.0.
Its just not present in the package.

This isn't correct. I can still apt-get php7.2-mysql. And it works.

The mysql() function was removed, not the driver.
Reply
#18
Solved: 4 Years, 1 Month ago
Why can't this be rolled back to PHP version 7.0.30?

That's what I am currently using for my website and it runs just fine.
I'm Serpius and You're Not    ¯\_(ツ)_/¯
DEAF GOLF
Reply
#19
Solved: 4 Years, 1 Month ago
(2018-07-08, 09:12 AM)Ben Cousins Wrote: This isn't correct. I can still apt-get php7.2-mysql. And it works.

The mysql() function was removed, not the driver.

Quote from Wiki PHP voting:
Quote:The mysql extension has been deprecated since PHP 5.5. The mysqli or PDO extension should be used instead. The deprecation has been decided in mysql_deprecation, where a discussion of the reasons behind this decision can be found.

If ext/mysql is removed as a bundled extension, it can still be made available as a PECL extension.

Vote result: Yes:28, No:12

Source: https://wiki.php.net/rfc/remove_deprecat...7#extmysql

Further read:
https://stackoverflow.com/questions/1285...es#tab-top

Its not impossible to have the extension present in a custom built (like bitnami one) package.
Reply
#20
Solved: 4 Years, 1 Month ago
Alright did some messing around and finally found the solution.

I backed up my site and removed it from my host then uploaded a fresh copy of MyBB and installed it while having PHP7 and it worked fine. I then removed the fresh install and re-uploaded my site and for some odd reason it works on PHP7 now? Confusing how that was the solution.

Thank you.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)