Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error warning
#1
Hello

since several weeks or so I'm getting error warnings in some of my styles and some of the pages, like this one

[fon‌t=Source Sans Pro]Warning[/font][fon‌t=Source Sans Pro] [2] A non-numeric value encountered - Line: 499 - File: inc/functions.php PHP 7.2.3 (Linux)[/font]
[fon‌t=Source Sans Pro]File
Line
Function/inc/functions.php
499
errorHandler->error
/global.php
459
my_date
/member.php
26
require_once[/font]


What can cause this errors and how can I solve this?
Reply
#2
This is because of the compatibility with PHP version you are using. Values required to be type-casted in 7.2+. Its a known issue and we are working on it.
However the error message you have posted is scattered and I am not being able to locate the lines causing error. Please post a screenshot of the error being encountered.
PGP fingerprint = 0CB4 140A 2BF2 48E4 6BA8  BB8D C386 35EE EC47 2CD0
Reply
#3
           
Thank your for the answer, I'm attaching three screenshot, showing different pages of different styles, mainly the error is listed about 30 times until the site would show up.
I don't know which sites of the forums are infected because it seems that this differs from style to style.

Hope that this can soon be fixed Sad

I've solved the problem by switching back to an older version of php
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)