Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [Error Message] User Registration not working
#1
Not Solved
So my new users aren't able to register due to this error:

https://gyazo.com/3d76b0ca0dce317a2325d7c5bae7d96c

They can get to the member.php page and fill out all the required details but as soon as they hit submit they get the image.

Link to my site: https://oculusgamingau.com/forums/member.php
Exisiting users can still log in or stay logged in but the member.php page isn't working.
Im running the latest version of MyBB 1.8.15
Reply
#2
Not Solved
You should revert the member_register templat to default it should fix the problem.
=> MY PLUGINS <=
Reply
#3
Not Solved
your database server is set to strict mode & it can be problematic while installing some plugins.
I'd suggest to contact your web host & request to disable strict mode of your database server.
Reply
#4
Not Solved
It has been working just fine tho, i have made no changes to the web server, plugins, forum its self. Nothing. But it just broke one day, ill talk to them to try turn it off but im just unsure to why it broke when nothing was changed.
Reply
#5
Not Solved
I disabled strict mode and it did fix the problem but i have gameserver databases aswell and the change made my gameserver crash a crazy amount so i had to revert back into strict mode.

Is there any other fix for this?

It's really strange how it just broke when i hadn't added/edited anything within the webserver/forums, so there must be a fix
Reply
#6
Not Solved
Strict Mode is very troublesome. You'd have to give the field 'ban_user' a default value of 0.
Plugin Count: I lost count.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply
#7
Not Solved
Wait whats the ban_user field going to affect people trying to create an account or log into their exisiting account??? If this is actually a fix then where is this default value to change it?
Reply
#8
Not Solved
Try the following:

ALTER TABLE mybb_users MODIFY banuser int NOT NULL default 0;
Plugin Count: I lost count.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply
#9
Not Solved
Where do i input that code?

Ok so i think i found it. I tried that code and got back: MySQL returned an empty result set (i.e. zero rows). (Query took 0.0011 seconds.)

I went looking for the ban_user field but it wasnt there as seen here https://gyazo.com/a9e125d91ca50b9f6e814f891820f44a

Should i make a INSERT INTO function to add the ban_user field in?

I just did a insert into strawberry that added ban_user column to the table but now its saying the 'thx' column doesnt have a default value. Is this gonna happen for every field in that table?
Reply
#10
Not Solved
Can you list the plugins that are activated on your board? I believe the columns MyBB is asking for are plugin-related.
Plugin Count: I lost count.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)