Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Days, 11 Hours, 19 Minutes ago Merging MyBB 1.8.11 forum with 1.8.16
#1
Solved: 4 Days, 11 Hours, 19 Minutes ago
Hello! I have my old database for a MyBB version 1.8.11 forum and I am attempting to merge it with a new installation on a different database of version 1.8.16. Whenever I get to merging "users," I am presented with the following error:

"MyBB has experienced an internal SQL error and cannot continue.

SQL Error:1054 - Unknown column 'aim' in 'field list'"

This happens as soon as I start importing users. Can anyone help? Thanks in advance!
Reply
#2
Solved: 4 Days, 11 Hours, 19 Minutes ago
drop the column aim in field list, probably added because of a plugin.
Reply
#3
Solved: 4 Days, 11 Hours, 19 Minutes ago
Do NOT upgrade to 1.8.16, wait for 1.8.17.
Reply
#4
Solved: 4 Days, 11 Hours, 19 Minutes ago
AIM has been removed from MyBB (it was there by default) as it’s been discontinued.
Plugin Count: 19 in total.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply
#5
Solved: 4 Days, 11 Hours, 19 Minutes ago
Ah okay, good to know. How do I go about removing it? Is there something I can do in myphpadmin or something?
Reply
#6
Solved: 4 Days, 11 Hours, 19 Minutes ago
Try the following, you will need to alter “mybb_” to suit your prefix (writing this via iPhone so apologies for miistakes):

Code:
ALTER TABLE mybb_users DROP aim;
Plugin Count: 19 in total.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply
#7
Solved: 4 Days, 11 Hours, 19 Minutes ago
I just put the code you gave as a Query in phpMyAdmin, is that right? Gave that a go, not sure if it worked though. I went through the database tables in phpMyAdmin and can't find anything related to AIM. I looked in the users table and there's stuff like Yahoo, Skype etc. but no AIM (which makes me think the command did remove it). I seem to still get the same error when I run the merge though. I'm rather new to most of this stuff so I may be doing something incorrectly.
Reply
#8
Solved: 4 Days, 11 Hours, 19 Minutes ago
It's only just caught my attention, why are you using the Merge system instead of the Upgrade system? If you're wanting to actually merge the two databases together, then upgrade your database to the latest version of MyBB and then use the Merge system.
Plugin Count: 19 in total.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply
#9
Solved: 4 Days, 11 Hours, 19 Minutes ago
I had tried to upgrade but I never seem to get that option when I navigate to the /install/ directory. It will only perform a fresh install that wipes all of my old posts and threads from my database. I'm trying to restore a myBB .sql backup which I have imported into a database. I'm not sure how to upgrade it since the only option I get is to just install myBB on the database which seems to overwrite everything. The documentation on restoring a database backup seems to only be for version 1.6.

Oh, just got it all to work! Edited the config.php file and changed the database name in there to the one I was using for the backup, then ran the upgrade. Thanks so much for your help everyone!
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)