Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [How To?] Change default language everywhere PERMANENTLY?
#1
Not Solved
Hello MyBB Community,

I'm currently trying to set the default language of my (2nd) forum. What have I done till now?:

-Copied and edited the old db (without any issues). Changed the inc/config.php
-Changed the inc/settings.php
-Changed inc/class_language.php

What is (not) my current problem?:

-My forum is working without any troubles.
-My admin cp tells me after each test configuration (of whatever) "Language english (/your-server-dir/the-forum-link/inc/languages/english) is not installed.

Everytime when this problem occurs I replace the inc/settings.php again and the problem is "solved" but if I try to change the settings again the problems occurs again [Image: huh.gif] . Btw. I also checked the module "index.php?module=--->config-settings<---" which loads with the index.php. There isn't anything what I have to change...I guess (?).

Where's problem? Can anyone give me advice (or maybe the solution)?

Sincerely Sauron.

-update-

I also edited the global.php. There was a entry $mybb->settings['bblanguage'] = 'english'; and I changed it to my language.
Reply
#2
Not Solved
You shouldn't edit the "inc/settings.php" file because it will be changed each time you change a setting in the ACP.
[Image: ZbrcFs]
Reply
#3
Not Solved
Also there is absolutely no need to change any file. You just need to make sure both global settings and user preferences are set correctly.
[Image: banner.png]
Reply
#4
Not Solved
(07-25-2018, 09:34 AM)StefanT Wrote: Also there is absolutely no need to change any file. You just need to make sure both global settings and user preferences are set correctly.

I deleted the inc/languages/english and setted a new path. I don't want that people must select the language.
I don't like that little button which can change your language. If the user connects then the matching language should be setted without the button.

(07-25-2018, 09:31 AM)chack1172 Wrote: You shouldn't edit the "inc/settings.php" file because it will be changed each time you change a setting in the ACP.

ikr but I couldn't change it when I deleted the english file. and why should MyBB work different? It still loads all stuff. Only the admcp after editing it via the gui (admcp -> settings) isn't working.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)