Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 8 Months, 4 Weeks, 2 Days ago Login logout Cookie problems. Please watch the attached video
#11
Solved: 8 Months, 4 Weeks, 2 Days ago
@hwmana

Your cookie settings like you have posted them are correct. I have seen this type problem before with MyBB but don't have a solution for you. Seems like a cache problem. The php version there was 7.0.3

I don't know what version MyBB is recommended to run at now, if it is 7.2

What goes around comes around



Reply
#12
Solved: 8 Months, 4 Weeks, 2 Days ago
(08-03-2018, 08:36 AM)Serpius Wrote:
(08-03-2018, 08:14 AM)Systmyz Wrote: Actually, the main link of the forums is www.Hardwaremana.com/Forums . Thus according to that, "/Forums/" will be the right choice. Correct me If I am wrong.


/forums/  -- Thank you to @Ashley1 for correcting me on this. 

Should be the correct input for the Cookie Path line.

The Cookie Domain with the '.' (dot) covers all sub-domains including /forums/

Try it and see what happens.

(08-03-2018, 08:50 AM)Systmyz Wrote: Actually, the main link of the forums is www.Hardwaremana.com/Forums . Thus according to that, "/Forums/" will be the right choice in cookie path. Correct me If I am wrong.

You are correct. 

I misread it and @Ashley1 corrected this.

Thanks!
I'm Serpius and You're Not    ¯\_(ツ)_/¯
[Image: 5M7sb0n.png?1]
Reply
#13
Solved: 8 Months, 4 Weeks, 2 Days ago
(08-03-2018, 08:36 AM)Serpius Wrote:
(08-03-2018, 08:14 AM)Systmyz Wrote: Actually, the main link of the forums is www.Hardwaremana.com/Forums . Thus according to that, "/Forums/" will be the right choice. Correct me If I am wrong.


/forums/  -- Thank you to @Ashley1 for correcting me on this. 

Should be the correct input for the Cookie Path line.

The Cookie Domain with the '.' (dot) covers all sub-domains including /forums

Try it and see what happens.

nothing changed by using "." as the cookie domain. Is there anything else that we can do?
Reply
#14
Solved: 8 Months, 4 Weeks, 2 Days ago
remove www from the URL , and try login from below address
http://hardwaremana.com/forums/member.php?action=login
check whether the login stays fine as you navigate around your forum ..
Reply
#15
Solved: 8 Months, 4 Weeks, 2 Days ago
The problem is with cache. I just checked you site and it is caching all pages.
[Image: ZbrcFs]
Reply
#16
Solved: 8 Months, 4 Weeks, 2 Days ago
(08-03-2018, 05:30 PM)chack1172 Wrote: The problem is with cache. I just checked you site and it is caching all pages.
Then whats the solution for this?
Reply
#17
Solved: 8 Months, 4 Weeks, 2 Days ago
I installed mybb 1.8.17 onto a test server with php 5.6 and 7.0 and can't replicate the problem, so the php version does not appear to be the problem. Must be some other (server) setting causing the problem.

@hwmana

I suspect you have something in your htaccess - either at the root level or the folder level where you have MyBB installed. Disable your .htaccess file(s) -> then clear you browser cache and restart the browser and your problem will be resolved.

What goes around comes around



Reply
#18
Solved: 8 Months, 4 Weeks, 2 Days ago
(08-03-2018, 10:54 PM)Ashley1 Wrote: I installed mybb 1.8.17 onto a test server with php 5.6 and 7.0 and can't replicate the problem, so the php version does not appear to be the problem. Must be some other (server) setting causing the problem.

@hwmana

I suspect you have something in your htaccess - either at the root level or the folder level where you have MyBB installed. Disable your .htaccess file(s) -> then clear you browser cache and restart the browser and your problem will be resolved.

Okay I will try it. BTW, on the main root ie. hardwaremana.com, we have a wordpress installation. Can that lead to such problems.

And how do you disable the htaccess file?

(08-03-2018, 05:28 PM).m. Wrote: remove www from the URL , and try login from below address
http://hardwaremana.com/forums/member.php?action=login
check whether the login stays fine as you navigate around your forum ..


We did this and the problem still remains.
Reply
#19
Solved: 8 Months, 4 Weeks, 2 Days ago
Having wordpress itself at the root won't cause the problem.

You can temporarily disable your htaccess files as i said above and then re enable them afterwards, after fixing or removing whatever is causing the problem inside htaccess.

So rename your .htaccess to something like htaccess and then see what happens.

Do this at the root and remember to clear the browser cache and restart the browser before checking your forum again.

What goes around comes around



Reply
#20
Solved: 8 Months, 4 Weeks, 2 Days ago
(08-04-2018, 03:39 PM)Ashley1 Wrote: Having wordpress itself at the root won't cause the problem.

You can temporarily disable your htaccess files as i said above and then re enable them afterwards, after fixing or removing whatever is causing the problem inside htaccess.

So rename your .htaccess to something like htaccess and then see what happens.

Do this at the root and remember to clear the browser cache and restart the browser before checking your forum again.

Okay, so I did jsut the way you said and renamed all the htaccess files to something else, cleared the cache and restart the browser. Still the same thing. Is there something that I need to do on the website as well.

Anything else you would like to suiggest?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)