Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is myBB compatible with Apache2+php7.0fpm?
#1
Haven't been on in a while and while searching if there was any known security flaws, I noticed some new releases.

My question is simple, would MyBB be compatible with an Apache Setup (using Ubuntu 16.04) and if so, what modules would be required other then php7 and MySQL

Also in regards to databasing, is MyBB compatible with .sqlite extensions? Also could a Sqlite database not require a password if over https?


Reply
#2
MyBB is fully compatible with Apache & PHP-FPM. In terms of Apache modules you'll likely want mod_deflate, mod_rewrite and mod_expires at the least.

MyBB itself is compatible with SQLite, but most plugins are designed with MySQL in mind rather than any other database engine so you might find issues in some plugins.
Reply
#3
(08-09-2018, 07:29 PM)Euan T Wrote: MyBB is fully compatible with Apache & PHP-FPM. In terms of Apache modules you'll likely want mod_deflate, mod_rewrite and mod_expires at the least.

MyBB itself is compatible with SQLite, but most plugins are designed with MySQL in mind rather than any other database engine so you might find issues in some plugins.

Awesome thank you, very helpful.


Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)