Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [JavaScript] Inline Moderation Problems
#1
Not Solved
I have tried a few threads I have seen regarding inline moderation, however I can't seem to get any of them to work. I can only soft delete threads, not permanently delete, move, etc. Please help! I can give you admin access to the forums if necessary! Thank you!
Reply
#2
Not Solved
(08-16-2018, 12:14 AM)Vindicent Wrote: I have tried a few threads I have seen regarding inline moderation, however I can't seem to get any of them to work. I can only soft delete threads, not permanently delete, move, etc. Please help! I can give you admin access to the forums if necessary! Thank you!

Well... if you had looked up a bit higher in this forum, you would have seen this THREAD.
I'm Serpius and You're Not    ¯\_(ツ)_/¯
[Image: y3xr3cj5]
Reply
#3
Not Solved
(08-16-2018, 12:29 AM)Serpius Wrote:
(08-16-2018, 12:14 AM)Vindicent Wrote: I have tried a few threads I have seen regarding inline moderation, however I can't seem to get any of them to work. I can only soft delete threads, not permanently delete, move, etc. Please help! I can give you admin access to the forums if necessary! Thank you!

Well... if you had looked up a bit higher in this forum, you would have seen this THREAD.

Well... if you read my thread, I have tried that. I have MyBB 1.8.17, and have tried that THREAD. It did not work, which is why I am here asking for help! Smile
Reply
#4
Not Solved
Check if the permissions are made correctly, or if all else fails, delete the role (if you can), or make a custom role with the permissions you need.

This can be done if you are the owner of the board or if you have administrative privileges. If this happens on someone else's board, report it to the Staff of that board.

IF THAT FAILS... You may need to reinstall MyBB.
[Image: logo.png]
Xyaena's Forums Webmaster
Reply
#5
Not Solved
(08-16-2018, 12:41 AM)Xyaena Wrote: Check if the permissions are made correctly, or if all else fails, delete the role (if you can), or make a custom role with the permissions you need.

This can be done if you are the owner of the board or if you have administrative privileges. If this happens on someone else's board, report it to the Staff of that board.

IF THAT FAILS... You may need to reinstall MyBB.

It's on my board and the administrators have full access so I'm not really sure what the problem is. I did see on a few threads where javascript was the error, and I'm just not sure how to go about fixing it
Reply
#6
Not Solved
(08-16-2018, 12:44 AM)Vindicent Wrote:
(08-16-2018, 12:41 AM)Xyaena Wrote: Check if the permissions are made correctly, or if all else fails, delete the role (if you can), or make a custom role with the permissions you need.

This can be done if you are the owner of the board or if you have administrative privileges. If this happens on someone else's board, report it to the Staff of that board.

IF THAT FAILS... You may need to reinstall MyBB.

It's on my board and the administrators have full access so I'm not really sure what the problem is. I did see on a few threads where javascript was the error, and I'm just not sure how to go about fixing it

So...

Does the website have Cloudflare?
I'm Serpius and You're Not    ¯\_(ツ)_/¯
[Image: y3xr3cj5]
Reply
#7
Not Solved
(08-16-2018, 12:58 AM)Serpius Wrote:
(08-16-2018, 12:44 AM)Vindicent Wrote:
(08-16-2018, 12:41 AM)Xyaena Wrote: Check if the permissions are made correctly, or if all else fails, delete the role (if you can), or make a custom role with the permissions you need.

This can be done if you are the owner of the board or if you have administrative privileges. If this happens on someone else's board, report it to the Staff of that board.

IF THAT FAILS... You may need to reinstall MyBB.

It's on my board and the administrators have full access so I'm not really sure what the problem is. I did see on a few threads where javascript was the error, and I'm just not sure how to go about fixing it

So...

Does the website have Cloudflare?
No sir it doesn't
Reply
#8
Not Solved
And an URL?
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#9
Not Solved
(08-16-2018, 06:55 AM)NoRules Wrote: And an URL?

www.vykorps.com/forums
Reply
#10
Not Solved
Hi,

in your headerinclude template, you have a javascript inside another javascript that's making some errors.

Clean first this (red color the problem):


Quote:<script type="text/javascript" src="http://www.vykorps.com/forums/images/generic/js/theme.js"></script>

<script type="text/javascript">
<!--
lang.unknown_error = "An unknown error has occurred.";

lang.select2_match = "One result is available, press enter to select it.";
lang.select2_matches = "{1} results are available, use up and down arrow keys to navigate.";
lang.select2_nomatches = "No matches found";
lang.select2_inputtooshort_single = "Please enter one or more character";
lang.select2_inputtooshort_plural = "Please enter {1} or more characters";
lang.select2_inputtoolong_single = "Please delete one character";
lang.select2_inputtoolong_plural = "Please delete {1} characters";
lang.select2_selectiontoobig_single = "You can only select one item";
lang.select2_selectiontoobig_plural = "You can only select {1} items";
lang.select2_loadmore = "Loading more results…";
lang.select2_searching = "Searching…";

var cookieDomain = ".vykorps.com";
var cookiePath = "/forums/";
var cookiePrefix = "";
var cookieSecureFlag = "0";
var deleteevent_confirm = "Are you sure you want to delete this event?";
var removeattach_confirm = "Are you sure you want to remove the selected attachment from this post?";
var loading_text = 'Loading. <br />Please Wait..';
var saving_changes = 'Saving changes..';
var use_xmlhttprequest = "1";
var my_post_key = "8e4e967f0c26a88838adee43e578f384";
var rootpath = "http://www.vykorps.com/forums";
var imagepath = "http://www.vykorps.com/forums/images/generic";
  var yes_confirm = "Yes";
var no_confirm = "No";
var MyBBEditor = null;
var spinner_image = "http://www.vykorps.com/forums/images/generic/spinner.gif";
var spinner = "<img src='" + spinner_image +"' alt='' />";
var modal_zindex = 9999;
// -->
<script type="text/javascript" src="http://www.vykorps.com/forums/jscripts/tabcontent.js">
</script>

to this:
Quote:<script type="text/javascript" src="http://www.vykorps.com/forums/images/generic/js/theme.js"></script>
<script type="text/javascript" src="http://www.vykorps.com/forums/jscripts/tabcontent.js">

<script type="text/javascript">
<!--
lang.unknown_error = "An unknown error has occurred.";

lang.select2_match = "One result is available, press enter to select it.";
lang.select2_matches = "{1} results are available, use up and down arrow keys to navigate.";
lang.select2_nomatches = "No matches found";
lang.select2_inputtooshort_single = "Please enter one or more character";
lang.select2_inputtooshort_plural = "Please enter {1} or more characters";
lang.select2_inputtoolong_single = "Please delete one character";
lang.select2_inputtoolong_plural = "Please delete {1} characters";
lang.select2_selectiontoobig_single = "You can only select one item";
lang.select2_selectiontoobig_plural = "You can only select {1} items";
lang.select2_loadmore = "Loading more results…";
lang.select2_searching = "Searching…";

var cookieDomain = ".vykorps.com";
var cookiePath = "/forums/";
var cookiePrefix = "";
var cookieSecureFlag = "0";
var deleteevent_confirm = "Are you sure you want to delete this event?";
var removeattach_confirm = "Are you sure you want to remove the selected attachment from this post?";
var loading_text = 'Loading. <br />Please Wait..';
var saving_changes = 'Saving changes..';
var use_xmlhttprequest = "1";
var my_post_key = "8e4e967f0c26a88838adee43e578f384";
var rootpath = "http://www.vykorps.com/forums";
var imagepath = "http://www.vykorps.com/forums/images/generic";
  var yes_confirm = "Yes";
var no_confirm = "No";
var MyBBEditor = null;
var spinner_image = "http://www.vykorps.com/forums/images/generic/spinner.gif";
var spinner = "<img src='" + spinner_image +"' alt='' />";
var modal_zindex = 9999;
// -->
</script>

BTW, this particular javascript (tabcontent.js) it's not found.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)