[Rejected] 403/404 Errors on changing between template groups to edit in ACP
#1
I get errors 403/404 when I am editing templates in ACP and move between template groups because a parameter wrongly gets carried over. 

How to reproduce: 
  1. Go to Admin CP > Templates & Style
  2. Expand one template group 
  3. (optional) click on one of the listed templates as if you want to edit it, save it to return to listing
  4. Click on another template group to expand it
  5. --> error
The URL in the browser (tested on latest Firefox and Chrome) looks like this: 

[site]/[acp path]/index.php?module=style-templates&sid=20&expand=2|7#group_7


as you can see, i opened template group 2 first, then tried to open group 7 and get an error. 

This started happening a few weeks ago while I still used 1.8.17 and keeps happening after upgrading to 1.8.19. I didn't change cookie settings or server side caching rules (on an apache/nginx) in the meantime.
Reply
#2
Which one do you get?

403 Forbidden or 404 Not Found? They’re two different errors.
Reply
#3
I know that it's different. On the surface it's usually  a 403 - forbidden but stating that access to a directory be forbidden which does not even exist, so occasionally i do get a 404 - not found, too. 
   
Reply
#4
This can't be a bug. I have never had these errors in the ACP, and can't replicate them even now.
What goes around comes around
Reply
#5
Oh ... ok. Thank you for testing that. Now I have to assume it is a local problem, maybe with the firewall settings.

P.S.: It was a firewall rule banning request strings containing the pipe symbol |
case closed
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)