Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved HTTPS doesn't load correctly
#1
Not Solved
I tried setting up https on my site. If I browse to my forum using http://www.nonewbs.com everything works as it should. If I browse to my forum using https://www.nonewbs.com I get the secure icon in the address bar but all I see on the screen is raw php data. The site doesn't appear to load correctly.
Reply
#2
Not Solved
Are you using shared hosting or is this a VPS or other server you've set up yourself? If it's shared hosting, you will need to contact your host.
Reply
#3
Not Solved
(10-16-2018, 07:31 PM)Euan T Wrote: Are you using shared hosting or is this a VPS or other server you've set up yourself? If it's shared hosting, you will need to contact your host.

It is an aws server that I control.
Reply
#4
Not Solved
(10-16-2018, 08:02 PM)dutchfo2o Wrote:
(10-16-2018, 07:31 PM)Euan T Wrote: Are you using shared hosting or is this a VPS or other server you've set up yourself? If it's shared hosting, you will need to contact your host.

It is an aws server that I control.

Are you using Nginx or Apache? It sounds like there is a difference between the virtual host configuration for the HTTPS version of the site and the standard version, with the HTTPS version not passing the PHP scripts back to PHP (PHP-FPM, PHP in FastCGI mode, or mod_php - depending on setup).
Reply
#5
Not Solved
(10-16-2018, 09:27 PM)Euan T Wrote:
(10-16-2018, 08:02 PM)dutchfo2o Wrote:
(10-16-2018, 07:31 PM)Euan T Wrote: Are you using shared hosting or is this a VPS or other server you've set up yourself? If it's shared hosting, you will need to contact your host.

It is an aws server that I control.

Are you using Nginx or Apache? It sounds like there is a difference between the virtual host configuration for the HTTPS version of the site and the standard version, with the HTTPS version not passing the PHP scripts back to PHP (PHP-FPM, PHP in FastCGI mode, or mod_php - depending on setup).

I am currently running apache. I do not have nginx installed.
Reply
#6
Not Solved
(10-16-2018, 10:31 PM)dutchfo2o Wrote:
(10-16-2018, 09:27 PM)Euan T Wrote:
(10-16-2018, 08:02 PM)dutchfo2o Wrote:
(10-16-2018, 07:31 PM)Euan T Wrote: Are you using shared hosting or is this a VPS or other server you've set up yourself? If it's shared hosting, you will need to contact your host.

It is an aws server that I control.

Are you using Nginx or Apache? It sounds like there is a difference between the virtual host configuration for the HTTPS version of the site and the standard version, with the HTTPS version not passing the PHP scripts back to PHP (PHP-FPM, PHP in FastCGI mode, or mod_php - depending on setup).

I am currently running apache. I do not have nginx installed.

Make sure you have something like the following in your Apache configuration then:

<FilesMatch \.php$>
  SetHandler application/x-httpd-php
</FilesMatch>

More information is available here, as the settings depend on how you're running PHP: https://wiki.apache.org/httpd/php
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)