Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Line Numbers Impossible To See in AdminCP Editor
#1
In editing any template or CSS file, the line numbers are impossible to see. 

The line numbers are "overlaying" the file text as shown in the screenshot. It's hard to see, but you can see it.

Look at the screenshot. This is from the MyBB default AdminCP. Any other AdminCP theme has the same problem as well.
This issue shows up even in the Advanced Mode in the 'Templates & Style' section of the AdminCP. (as shown in the second screenshot)

How can I fix this so that the line numbers can be seen better and not interfere with the text in the file?

[Image: 9785959c489b3808a32118097bdab1df.png]

[Image: 24a2ace837e116a0baefcd1167a5c2f3.png]
I'm Serpius and You're Not
[Image: 5M7sb0n.png?1]
Reply
#2
Open this css file:
admin/jscripts/codemirror/theme/mybb.css
and see at line no. 6 if it is there:
.cm-s-mybb .CodeMirror-linenumber { color: white; }

If not try adding it, if yes - append 'important'
.cm-s-mybb .CodeMirror-linenumber { color: white !important; }

If the issue still not resolved, open this css:
admin/jscripts/codemirror/lib/codemirror.css

Go to line no. 36:

.CodeMirror-linenumber {
padding: 0 3px 0 5px;
min-width: 20px;
text-align: right;
color: #999;
white-space: nowrap;
}

Change the color to 'white'.
Disclaimer: Don't be misguided looking at my usergroup and assume whatever I say is official. When I speak in community I am just a member with personal opinions.
Reply
#3
(11-08-2018, 05:43 AM)effone Wrote: Open this css file:
admin/jscripts/codemirror/theme/mybb.css
and see at line no. 6 if it is there:
.cm-s-mybb .CodeMirror-linenumber { color: white; }

If not try adding it, if yes - append 'important'
.cm-s-mybb .CodeMirror-linenumber { color: white !important; }

If the issue still not resolved, open this css:
admin/jscripts/codemirror/lib/codemirror.css

Go to line no. 36:

.CodeMirror-linenumber {
 padding: 0 3px 0 5px;
 min-width: 20px;
 text-align: right;
 color: #999;
 white-space: nowrap;
}

Change the color to 'white'.

Thanks to @effone!

I had to append "!important" to get it to work properly.

Was the code originally done without the "!important" in it? Meaning, does that how it looks like when we get the install package?
I am curious because I am wondering if another AdminCP theme had removed "!important" from that line. 
Or a different AdminCP theme possibly replaced the mybb.css with its own copy, which would have not included the "!important" in that part of the code? 
I'm Serpius and You're Not
[Image: 5M7sb0n.png?1]
Reply
#4
Some other color property with the same class was overriding your color. You can easily identify using 'inspect'.

Using !important is never a recommendation unless you HAVE TO.
By default the mybb.css works fine, other ACP theme should take care of that part while being developed.
Disclaimer: Don't be misguided looking at my usergroup and assume whatever I say is official. When I speak in community I am just a member with personal opinions.
Reply
#5
FASTyle replaces default's codemirror with an enhanced version; usually uninstalling the plugin works just fine, but in your particular case, you are using a custom ACP theme which kinda interferes with FASTyle's codemirror version I suppose.

The solution is simple as restoring the original file, or blame your theme and work it out by overriding CSS rules.
[Image: fSGNVQj.png]
Reply
#6
(11-08-2018, 09:08 AM)Shade Wrote: FASTyle replaces default's codemirror with an enhanced version; usually uninstalling the plugin works just fine, but in your particular case, you are using a custom ACP theme which kinda interferes with FASTyle's codemirror version I suppose.

The solution is simple as restoring the original file, or blame your theme and work it out by overriding CSS rules.

This does not make any sense "blame your theme and work it out by overriding CSS rules" because the same issue showed up in the DEFAULT copy of the AdminCP of MyBB installation. That's exactly what I said in my original post.

Go ahead blame the developers of the MyBB theme for that one, but keep me out of it.
I'm Serpius and You're Not
[Image: 5M7sb0n.png?1]
Reply
#7
Sorry I didn't read it properly, but I didn't want to be rude either. "Blame your theme" wasn't a personal offense, just a heads up for you to adjust the theme (or ask the dev to do so). Regardless of this, I double-checked this and FASTyle isn't involved in the issue as it does not replace that particular file, but just CodeMirror's default stylesheet.
[Image: fSGNVQj.png]
Reply
#8
Quote:because the same issue showed up in the DEFAULT copy of the AdminCP of MyBB installation.

No it doesn't.
... and no need to be harsh for every single petty issue towards MyBB development team. Please...
Disclaimer: Don't be misguided looking at my usergroup and assume whatever I say is official. When I speak in community I am just a member with personal opinions.
Reply
#9
(11-08-2018, 03:13 PM)effone Wrote:
Quote:because the same issue showed up in the DEFAULT copy of the AdminCP of MyBB installation.

No it doesn't.
... and no need to be harsh for every single petty issue towards MyBB development team. Please...

Don't misunderstand me... that comment was NOT directed at the development team, it was directed to Shade.

I was trying to clarify (without much success) to Shade exactly what I said in my original post.
I'm Serpius and You're Not
[Image: 5M7sb0n.png?1]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)